[erlang-questions] A simple multiply in the shell will kill the shell and its supervisor

Steve Kirsch steve.kirsch@REDACTED
Mon Apr 20 09:32:14 CEST 2009

This only seems to kill erlang's shell permanently using erl on Windows.
werl on the same machine works fine.

Startup erl on windows.

type in one line:
852984. B=A*A*A*A*A. C=B*B*B*B*B*B*B*B*B*B*B. D=C*C*C*C*C*C*C*C*C*C*C.

then your erl will stop responding. It isn't in a loop and it isn't
using up cpu or crash dumping. 

It is just completely dead.

I've tried this on two completely different PC's running windows XP Pro
with the same result. You do it on werl on the same machine, everything
is fine. Do it from erl, and it hangs.

i am using R12B.

inspection via a remote shell reveals that these processes have
disappeared from i() listing:
<0.26.0>              supervisor_bridge:user_sup/1           233
81    0
                      gen_server:loop/6                        9

<0.28.0>              user:server/2                          377
600    0
user                  user:get_chars/7                        21

<0.29.0>              erlang:apply/2                        4181
4649    0
                      shell:get_command1/5                    16

<0.35.0>              erlang:apply/2                        1597
2550    0
                      shell:eval_loop/3                        6

why is this happening?

More information about the erlang-questions mailing list