R9B-1 build notes on RH9

Erik Pearson erikp@REDACTED
Tue Apr 8 23:21:42 CEST 2003

Just installed RedHat 9 on a new system;  added latest
patches as well.  So, I thought I'd pass some build notes
to the maintainers or anyone else.

1.  Always  have had troubles with unicode and the
perl build scripts.  I always change LANG=en_US
from the default en_US.UTF-8 before building.

2.  Applications ssl now fails.  Haven't seen this before,
so I'm guessing RH put krb5.h in a new place.

gcc -c -o ../priv/obj/i686-pc-linux-gnu/esock_ssleay.o -Wall -g -O2 
-I/home/erikp/otp_src_R9B-1/erts/i686-pc-linux-gnu  -DHAVE_CONFIG_H -O2 
-I/usr/include/openssl -I/usr/include esock_ssleay.c
In file included from /usr/include/openssl/ssl.h:179,
                 from esock_ssleay.c:74:
/usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory
In file included from /usr/include/openssl/ssl.h:179,
                 from esock_ssleay.c:74:

krb5.h is found in /usr/kerberos/include.  Adding an appropriate 
solved it.

3.  Ssl_esock didn't get installed, so ssl:start() failed.

I manually copied $ERL_TOP/lib/ssl/priv/bin/i686-pc-linux-gnu/ssl_esock
to <prefix>/lib/erlang/lib/ssl-2.3.5/priv/bin/ssl_esock

Then 'ssl:start()' worked.

Other than that, so far so good.


More information about the erlang-questions mailing list