make problems

Per Hedeland per@REDACTED
Thu Nov 2 15:25:48 CET 2000

Kent Boortz <kent@REDACTED> wrote:
>> When i run ./configure, at the end i get an error about it not being
>> able to create the directory
>> /usr/local/erlang/otp_src_R7B-0/lib/gs/c_src/lib/tcl7.6/unix. It
>> then goes on about "i assume that there is standalone support"
>This I haven't seen before and can't think of a reason.

I think you always get this - it's just a leftover from the original
tcl/tk build system, and can be safely ignored - this is the exact text
(from running configure on FreeBSD 4.1):

== Warning: Your libtcl76.a is not yet created in the directory
   /usr/local/src/otp_src_R7B-0/lib/gs/c_src/lib/tcl7.6/unix, so I cannot determine this.
   For now I just assume there is standalone support.
   If you get an error later during the build of wish.standalone,
   then first compile Tcl7.6 with standalone support.

>> The Makefile is created but when i run make i get an rc: Command not found
>> error. What is this rc command
>I think this is becuase of a bug in the configure script. The symbol
>AR was never set when 'ar' was nog found. Make sure you have a 'ar'
>program in your path. Try it and get back if you still have problems.

Yes, you need /usr/ccs/bin in your $PATH to build most any source
package on Solaris. The bug should be fixed though, it has come up
before - perhaps something like the below (totally untested!:-).

--Per Hedeland

--- erts/autoconf/	Wed Sep 13 14:14:20 2000
+++ erts/autoconf/	Thu Nov  2 15:23:50 2000
@@ -139,7 +139,10 @@
-AC_CHECK_PROG(AR, ar, ar)
+AC_CHECK_PROG(AR, ar, ar, notfound)
+if test "$AR" = "notfound"; then
+  AC_MSG_ERROR([No 'ar' command found in PATH])
 dnl We can live with Solaris /usr/ucb/install

More information about the erlang-questions mailing list