<html>
  <head>
    <meta content="text/html; charset=utf-8" http-equiv="Content-Type">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    Sorry I forgot to reply to the list. Yes, the problem was that on
    the production server, the console backend was not started.<br>
    <br>
    Regards,<br>
    Martin<br>
    <br>
    <div class="moz-cite-prefix">On 2/14/2016 10:19 PM, Mark Allen
      wrote:<br>
    </div>
    <blockquote
      cite="mid:463923366.4135845.1455481195079.JavaMail.yahoo@mail.yahoo.com"
      type="cite">
      <div style="color:#000; background-color:#fff;
        font-family:verdana, helvetica, sans-serif;font-size:13px">
        <div id="yui_3_16_0_1_1455476110505_50036"><span>Hi.</span></div>
        <div id="yui_3_16_0_1_1455476110505_50223"><span><br>
          </span></div>
        <div dir="ltr" id="yui_3_16_0_1_1455476110505_50037"><span
            id="yui_3_16_0_1_1455476110505_50205">The OTP docs for
            gen_event:call state:</span></div>
        <blockquote style="margin: 0 0 0 40px; border: none; padding:
          0px;" id="yui_3_16_0_1_1455476110505_49970">
          <div dir="ltr" id="yui_3_16_0_1_1455476110505_49876"><span
              style="font-family: Verdana, Arial, Helvetica,
              sans-serif;" id="yui_3_16_0_1_1455476110505_49871"
              class="">If the specified event handler is not installed,
              the function returns¬†</span><span class=""
              style="font-family: Courier, monospace;"
              id="yui_3_16_0_1_1455476110505_49873">{error,bad_module}</span><span
              style="font-family: Verdana, Arial, Helvetica,
              sans-serif;" id="yui_3_16_0_1_1455476110505_49875"
              class="">.</span></div>
          <div dir="ltr" id="yui_3_16_0_1_1455476110505_49876"><br>
          </div>
        </blockquote>
        <div dir="ltr" id="yui_3_16_0_1_1455476110505_49817">I see that
          the application is loaded from the screen shot; did you start
          the lager application and a console backend before trying to
          set a new log level? ¬†"Starting" the application registers
          lager_console_backend as a gen_event handler. You may also
          want to use lager:trace_console/1</div>
        <div dir="ltr" id="yui_3_16_0_1_1455476110505_49817"><br>
        </div>
        <div dir="ltr" id="yui_3_16_0_1_1455476110505_49817">Thanks.</div>
        <div dir="ltr" id="yui_3_16_0_1_1455476110505_49817"><br>
        </div>
        <div dir="ltr" id="yui_3_16_0_1_1455476110505_49817">Mark</div>
        <div dir="ltr" id="yui_3_16_0_1_1455476110505_49817"><br>
        </div>
        <div dir="ltr" id="yui_3_16_0_1_1455476110505_49817"><br>
        </div>
        <div class="qtdSeparateBR"><br>
          <br>
        </div>
        <div class="yahoo_quoted" style="display: block;">
          <div style="font-family: verdana, helvetica, sans-serif;
            font-size: 13px;">
            <div style="font-family: HelveticaNeue, Helvetica Neue,
              Helvetica, Arial, Lucida Grande, sans-serif; font-size:
              16px;">
              <div dir="ltr"><font size="2" face="Arial"> On Sunday,
                  February 7, 2016 11:06 AM, Martin Koroudjiev
                  <a class="moz-txt-link-rfc2396E" href="mailto:mrtndimitrov@gmail.com"><mrtndimitrov@gmail.com></a> wrote:<br>
                </font></div>
              <br>
              <br>
              <div class="y_msg_container">
                <div id="yiv7091349785">
                  <div> Hello,<br>
                    <br>
                    I have to trace a bug on a production server running
                    lager. I connected to the node and tried to change
                    the log level to debug but got a strange error -
                    bad_module.<br>
                    I've checked and lager is running. Here is a
                    screenshot of the commands:<br>
                    <br>
                    <img moz-do-not-send="true" alt=""><br>
                    <br>
                    Thanks in advance,<br>
                    Martin<br>
                  </div>
                </div>
                <br>
                _______________________________________________<br>
                erlang-questions mailing list<br>
                <a moz-do-not-send="true"
                  ymailto="mailto:erlang-questions@erlang.org"
                  href="mailto:erlang-questions@erlang.org">erlang-questions@erlang.org</a><br>
                <a moz-do-not-send="true"
                  href="http://erlang.org/mailman/listinfo/erlang-questions"
                  target="_blank">http://erlang.org/mailman/listinfo/erlang-questions</a><br>
                <br>
                <br>
              </div>
            </div>
          </div>
        </div>
      </div>
    </blockquote>
    <br>
  </body>
</html>