<div dir="ltr"><div>And the help was very much appreciated! I installed kerl ran it as suggested. Went in to<br><br>~/.kerl/builds/17.3.4/otp_src_git<br><br>and ran:<br><br>sudo make install<br><br>and I was on my way!<br><br></div><div>Merci!<br></div><div><br></div>-wes<br></div><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Dec 3, 2014 at 3:29 PM, Loc Hoguin <span dir="ltr"><<a href="mailto:essen@ninenines.eu" target="_blank">essen@ninenines.eu</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">I'd like to add my 2 cents.<br>
<br>
Many users are hit by this issue, and many users will be hit by this issue at least until 17.4 is released (and that's me hoping 17.4 will be an official release).<br>
<br>
A week ago I helped 2 users solve this issue on this very same mailing list (solution: using kerl git, or downgrade).<br>
<br>
Yesterday I helped a user by email that had this issue.<br>
<br>
Over just the past couple weeks I also had some tickets or answered IRC questions about this issue, both for my software, other third party software and software coming with OTP (httpc).<br>
<br>
It is my opinion that it was a terrible decision (if one was even considered) not to have made 17.3.2 be a full official release. This bug breaks several applications that come with OTP. All code that uses SSL as a client is broken. We can only hope that few users will decide to settle on 17.3, because otherwise we will have to "fix" this issue for a long time to come.<br>
<br>
It is a breaking bug the same way syntax_tools was broken before and a new release was issued. I am not sure why this didn't happen this time? There's probably more code that makes use of the client SSL code than syntax_tools...<br>
<br>
Hope this email does not sound too catastrophic...<div><div class="h5"><br>
<br>
On 12/03/2014 11:14 PM, Benoit Chesneau wrote:<br>
</div></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div><div class="h5">
It has been probably answered before, but what is the reason to not make<br>
official release for minor updates? Ie. when a version is tagged a<br>
release could be made available to the community. Today that could be<br>
done using any CI tool so I guess the reason is other.<br>
<br>
I am asking because today an SSL issue was raised in hackney. I am<br>
generally using the latest tag, or recent version so I didn't noticed<br>
that the code I was using wasn't working for all certificates on<br>
previous version:<br>
<br>
<a href="https://github.com/benoitc/hackney/issues/141" target="_blank">https://github.com/benoitc/<u></u>hackney/issues/141</a><br>
<br>
I am not sure right now how to solve such issue. Is there a way to test<br>
the minor version available? On the other hand sometimes as a temporary<br>
workaround I could point someone to use the last release. But in this<br>
case that not simple, since it imply a build and in some infrastructure<br>
it would be impossible. How others do?<br>
<br>
- benoit<br>
<br>
<br></div></div>
______________________________<u></u>_________________<br>
erlang-questions mailing list<br>
<a href="mailto:erlang-questions@erlang.org" target="_blank">erlang-questions@erlang.org</a><br>
<a href="http://erlang.org/mailman/listinfo/erlang-questions" target="_blank">http://erlang.org/mailman/<u></u>listinfo/erlang-questions</a><br>
<br><span class="HOEnZb"><font color="#888888">
</font></span></blockquote><span class="HOEnZb"><font color="#888888">
<br>
-- <br>
Loc Hoguin<br>
<a href="http://ninenines.eu" target="_blank">http://ninenines.eu</a><br>
______________________________<u></u>_________________<br>
erlang-questions mailing list<br>
<a href="mailto:erlang-questions@erlang.org" target="_blank">erlang-questions@erlang.org</a><br>
<a href="http://erlang.org/mailman/listinfo/erlang-questions" target="_blank">http://erlang.org/mailman/<u></u>listinfo/erlang-questions</a><br>
</font></span></blockquote></div><br></div>