<div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)">Ok,</div><div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)">
<br></div><div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)">I finally managed to track this down but I'm totally unsure why this happens.┬áMotiejus, you were right.</div>
<div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)"><br></div><div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)">
When I run REBAR, the process automountd tries to connect on port 111 (sunrpc) on my local NAT. When it times out, the CT tests are actually run. If I simply block this process with a firewall, tests start immediately.</div>
<div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)"><br></div><div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)">
I'm at disposal if anyone wants to dig further (tuncer?)</div><div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)"><br></div><div style="color:rgb(34,34,34);font-family:arial,sans-serif;font-size:13px;background-color:rgb(255,255,255)">
r.</div><br><div class="gmail_quote">On Wed, Sep 26, 2012 at 1:38 PM, Tuncer Ayaz <span dir="ltr"><<a href="mailto:tuncer.ayaz@gmail.com" target="_blank">tuncer.ayaz@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<div class="im">On Wed, Sep 26, 2012 at 9:44 PM, Motiejus Jak┼ítys wrote:<br>
> On Wed, Sep 26, 2012 at 8:40 PM, Roberto Ostinelli wrote:<br>
> > > How do you run it? Consistent 20 seconds sounds like a DNS<br>
> > > timeout issue (stab in the dark).<br>
> ><br>
> ><br>
> > rebar ct_suites=mymodule<br>
><br>
> Hi,<br>
> adding the list.<br>
><br>
> Please do<br>
><br>
> $TRACE_F rebar ct_suites=mymodule<br>
<br>
</div>Make that<br>
<br>
$TRACE_F rebar suites=mymodule<br>
<br>
and also consider running rebar with fprof:<br>
<br>
$TRACE_F rebar -p suites=mymodule<br>
or<br>
$TRACE_F rebar --profile suites=mymodule<br>
<br>
, but make sure you update rebar first to avoid a faulty<br>
call to fprof:apply/2.<br>
<br>
If it's caused by name lookup, you can try a custom ERL_INETRC file:<br>
<a href="http://www.erlang.org/doc/apps/erts/inet_cfg.html" target="_blank">http://www.erlang.org/doc/apps/erts/inet_cfg.html</a><br>
<div class="HOEnZb"><div class="h5"><br>
> and replace $TRACE_F with Max OS C equivalent of "strace -f".<br>
> Then see what it does just before the 20 second pause.<br>
</div></div></blockquote></div><br>