Hi, Siri!<div><br></div><div>I figured out that it's not important to start sasl, and it's sufficient just to load it (see the included applications below the started ones). Just to be sure, tried to make an upgrade that doesn't stop or unload sasl, and the system still behaves in the same way.</div>

<div><br></div><div>For what it's worth, the occurring error with lager is related to dynamic code compiling (it's basically a copied mochiglobal module).</div><div><br></div><div>Will try to use the latest Erlang, I've been testing this stuff in R14B04.<br>
<br><div class="gmail_quote">On Mon, Sep 10, 2012 at 11:58 AM, Siri Hansen <span dir="ltr"><<a href="mailto:erlangsiri@gmail.com" target="_blank">erlangsiri@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi Dmitry!<div>I didn't look very closely at this, but I wonder where sasl is? If you are using the release_handler for upgrade, you need to include sasl in your releases.</div>

<div>/siri</div><div><br><div class="gmail_quote">
2012/9/8 Dmitry Demeshchuk <span dir="ltr"><<a href="mailto:demeshchuk@gmail.com" target="_blank">demeshchuk@gmail.com</a>></span><br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

<div><div>
Okay, that seems like a lager problem, it just doesn't start even after starting compiler.<div><br></div><div>Moreover, it doesn't start using lager:start() and whatever else. No idea why compiler isn't started though.<div>


<div><br>
<br><div class="gmail_quote">On Sat, Sep 8, 2012 at 8:37 PM, Dmitry Demeshchuk <span dir="ltr"><<a href="mailto:demeshchuk@gmail.com" target="_blank">demeshchuk@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">



Hi, everyone.<div><br></div><div>I've been checking rebar and releases mechanisms and noticed an odd thing.</div><div><br></div><div>First, I created a dummy release and started it. After that, I added some applications to it, generated a release upgrade and installed it. Surprisingly, some applications haven't started, compiler and lager to be precise.</div>




<div><br></div><div>Basically, here was the initial list of applications in reltool.config:</div><div><br></div><div><div>    kernel,</div><div>    stdlib,</div><div>    rels</div></div><div><br></div><div>




and here's the one after my upgrade:</div><div><br></div><div><div>    kernel,</div><div>    stdlib,</div><div>    riak_err,</div><div>    compiler,</div><div>    syntax_tools,</div><div>    lager,</div>




<div>    rels</div></div><div><br></div><div>No errors, no warnings, compiler and lager just silently fail to start, though their starting instructions do exist in relup. Tried to start them manually  works like a charm.</div>




<div><br></div><div>Here's a short exapmle:<a href="https://github.com/doubleyou/rels" target="_blank">https://github.com/doubleyou/rels</a></div><div>To reproduce, switch to the initial commit, build, generate release. Then switch to the second commit, build, generate release upgrade, install.</div>




<div><br></div><div><br></div><div>Any suggestions?</div><span><font color="#888888"><div><div><br></div>-- <br>Best regards,<br>Dmitry Demeshchuk<br>
</div>
</font></span></blockquote></div><br><br clear="all"><div><br></div>-- <br>Best regards,<br>Dmitry Demeshchuk<br>
</div></div></div>
<br></div></div>_______________________________________________<br>
erlang-questions mailing list<br>
<a href="mailto:erlang-questions@erlang.org" target="_blank">erlang-questions@erlang.org</a><br>
<a href="http://erlang.org/mailman/listinfo/erlang-questions" target="_blank">http://erlang.org/mailman/listinfo/erlang-questions</a><br>
<br></blockquote></div><br></div>
</blockquote></div><br><br clear="all"><div><br></div>-- <br>Best regards,<br>Dmitry Demeshchuk<br>
</div>