<font size=2 face="sans-serif">Dear colleagues, </font>
<br>
<br><font size=2 face="sans-serif">Thanks, for the quick reply. The issue
with the </font><tt><font size=2>crypto.c</font></tt><font size=2 face="sans-serif">
 clearly relates to OpenSSL. Unfortunately an openssl-devel package
is not available from Novell SUSE.  I've downloaded the latest source
packages of Kerberos 5 (MIT) and as well as OpenSSL. Remains some doubts
how to use the configuration arguments described in the Erlang install
process </font>
<br>
<br><tt><font size=3>--with-ssl=PATH</font></tt><font size=3> - Specify
location of OpenSSL include and lib </font>
<br>
<br><font size=2 face="sans-serif">Is there an example how to setup this
PATH?  </font>
<br>
<br><font size=2 face="sans-serif"><u>Questions: </u></font>
<br>
<br><font size=2 face="sans-serif">1  - What exactly goes into the
PATH argument of </font><tt><font size=2>with-ssl=</font></tt><font size=2 face="sans-serif">
? Is there an example how to use it?   </font>
<br>
<br><font size=2 face="sans-serif">2  - Why does the /configure shell
search for the </font><tt><font size=2>krb5.h</font></tt><font size=2 face="sans-serif">
only under the location of </font><tt><font size=2> /usr/include</font></tt><font size=2 face="sans-serif">
 </font>
<br>
<br><font size=2 face="sans-serif">Those are the locations generated by
Kerberos5:  </font>
<br><tt><font size=2>    /usr/local/include/krb5.h</font></tt>
<br><tt><font size=2>    /usr/local/include/krb5/krb5.h</font></tt>
<br>
<br><font size=2 face="sans-serif">and for the openssl package</font>
<br><tt><font size=2>    /usr/local/ssl/bin/openssl</font></tt>
<br><tt><font size=2>    /usr/local/ssl/include/openssl</font></tt>
<br>
<br><tt><font size=2>3. </font></tt><font size=2 face="sans-serif">Any
modules need to be placed under </font><tt><font size=2>/usr/include</font></tt><font size=2 face="sans-serif">
(default path of  ./configure) ? </font>
<br>
<br><font size=2 face="sans-serif">Thanks in advance for your support to
add crypto (ssl) suport to Erlang. </font>
<br>
<br><font size=2 face="sans-serif">Regards, </font>
<br><font size=2 face="sans-serif">Claude</font>
<br><font size=2 face="sans-serif"><br>
</font><font size=1 color=#a2a2a2 face="Arial"><b><br>
Claude Falbriard <br>
Certified IT Specialist L2 - Middleware<br>
AMS Hortolndia / SP - Brazil<br>
phone:    +55 19 9837 0789<br>
cell:         +55 13 8117 3316<br>
e-mail:    claudef@br.ibm.com<br>
</b></font>
<br>
<br>
<br>
<br><font size=1 color=#5f5f5f face="sans-serif">From:      
 </font><font size=1 face="sans-serif">CGS <cgsmcmlxxv@gmail.com></font>
<br><font size=1 color=#5f5f5f face="sans-serif">To:      
 </font><font size=1 face="sans-serif">claudef@br.ibm.com</font>
<br><font size=1 color=#5f5f5f face="sans-serif">Cc:      
 </font><font size=1 face="sans-serif">Erlang-Questions Questions
<erlang-questions@erlang.org></font>
<br><font size=1 color=#5f5f5f face="sans-serif">Date:      
 </font><font size=1 face="sans-serif">26/04/2012 10:03</font>
<br><font size=1 color=#5f5f5f face="sans-serif">Subject:    
   </font><font size=1 face="sans-serif">Re: [erlang-questions]
Issues with Erlang Build under SUSE SLES 11 SP 1 on S390</font>
<br>
<hr noshade>
<br>
<br>
<br><font size=3>Hi,<br>
<br>
I suppose you need to install OpenSSL-dev (from the error it looks like
you are missing some OpenSSL headers).<br>
<br>
CGS<br>
<br>
<br>
<br>
<br>
</font>
<br><font size=3>On Thu, Apr 26, 2012 at 2:17 PM, <</font><a href=mailto:claudef@br.ibm.com target=_blank><font size=3 color=blue><u>claudef@br.ibm.com</u></font></a><font size=3>>
wrote:</font>
<br><font size=3 face="sans-serif">Dear colleagues,</font><font size=3>
<br>
</font><font size=3 face="sans-serif"><br>
 I'm compiling an Erlang  environment under the SUSE SLES 11
SP1 on a S390 platform building it from the source. I'm facing an error
condition when adding the support for OpenSSL and Erlang "crypto"
support using the following configuration: </font><font size=3><br>
</font><font size=3 face="sans-serif"><br>
.</font><tt><font size=3>/configure --with-ssl --with-ssl=/usr/lib64/openssl</font></tt><font size=3>
<br>
</font><font size=3 face="sans-serif"><br>
The configure completes normal, but the subsequent "make" step
throws a sequence of errors like this: <br>
.. </font><tt><font size=3><br>
crypto.c: In function hmac_md5:</font></tt><font size=3> </font><tt><font size=3><br>
crypto.c:1713: error: MD5_CTX undeclared (first use in this function)</font></tt><font size=3>
</font><tt><font size=3><br>
crypto.c:1713: error: expected ; before ctx</font></tt><font size=3>
</font><tt><font size=3><br>
crypto.c:1714: warning: ISO C90 forbids mixed declarations and code</font></tt><font size=3>
</font><tt><font size=3><br>
crypto.c:1737: error: ctx undeclared (first use in this function)</font></tt><font size=3>
</font><tt><font size=3><br>
crypto.c: In function hmac_sha1:</font></tt><font size=3> </font><tt><font size=3><br>
crypto.c:1752: error: SHA_CTX undeclared (first use in this function)</font></tt><font size=3>
</font><tt><font size=3><br>
crypto.c:1752: error: expected ; before ctx</font></tt><font size=3>
</font><tt><font size=3><br>
crypto.c:1753: warning: ISO C90 forbids mixed declarations and code</font></tt><font size=3>
</font><tt><font size=3><br>
crypto.c:1776: error: ctx undeclared (first use in this function)</font></tt><font size=3>
</font><tt><font size=3><br>
make[4]: *** [../priv/obj/s390x-ibm-linux-gnu/crypto.o] Error 1</font></tt><font size=3>
</font><tt><font size=3><br>
make[4]: Leaving directory `/opt/erlang/otp_src_R14B03/lib/crypto/c_src'</font></tt><font size=3>
</font><tt><font size=3><br>
make[3]: *** [opt] Error 2</font></tt><font size=3> </font><tt><font size=3><br>
make[3]: Leaving directory `/opt/erlang/otp_src_R14B03/lib/crypto/c_src'</font></tt><font size=3>
</font><tt><font size=3><br>
make[2]: *** [opt] Error 2</font></tt><font size=3> </font><tt><font size=3><br>
make[2]: Leaving directory `/opt/erlang/otp_src_R14B03/lib/crypto'</font></tt><font size=3>
</font><tt><font size=3><br>
make[1]: *** [opt] Error 2</font></tt><font size=3> </font><tt><font size=3><br>
make[1]: Leaving directory `/opt/erlang/otp_src_R14B03/lib'</font></tt><font size=3>
</font><tt><font size=3><br>
make: *** [libs] Error 2</font></tt><font size=3> </font><tt><font size=3><br>
..</font></tt><font size=3> <br>
</font><font size=3 face="sans-serif"><br>
 Without OpenSSL support, the Erlang package compiles successfully
and I've tested it with the console prompt. <br>
Thanks in advance for your hints how to fix this issue with the crypto
module. <br>
  <br>
Regards, <br>
Claude <br>
</font><font size=1 color=#a2a2a2 face="Arial"><b><br>
<br>
Claude Falbriard <br>
Certified IT Specialist L2 - Middleware<br>
AMS Hortolndia / SP - Brazil<br>
phone:    +55 19 9837 0789<br>
cell:         +55 13 8117 3316<br>
e-mail:    </b></font><a href=mailto:claudef@br.ibm.com target=_blank><font size=1 color=blue face="Arial"><b><u>claudef@br.ibm.com</u></b></font></a><font size=3><br>
<br>
_______________________________________________<br>
erlang-questions mailing list</font><font size=3 color=blue><u><br>
</u></font><a href="mailto:erlang-questions@erlang.org"><font size=3 color=blue><u>erlang-questions@erlang.org</u></font></a><font size=3 color=blue><u><br>
</u></font><a href="http://erlang.org/mailman/listinfo/erlang-questions" target=_blank><font size=3 color=blue><u>http://erlang.org/mailman/listinfo/erlang-questions</u></font></a><font size=3><br>
</font>
<br>
<br>