<div class="gmail_quote">On Sat, Apr 14, 2012 at 12:43 AM, Andrew Wiley <span dir="ltr"><<a href="mailto:wiley.andrew.j@gmail.com">wiley.andrew.j@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">

Hello,
<div><br></div><div>I'm trying to get Erlang with HiPE to build on an ARMv7 box (a Trimslice -†<a href="http://trimslice.com/web/" target="_blank">http://trimslice.com/</a>†), and I'm getting an undefined reference to am_arm. I'm building R15B01, and the build commands I'm using are:</div>


<div>./otp_build autoconf</div><div>./otp_build configure --enable-native-libs --enable-hipe --prefix=/usr --enable-smp-support --enable-threads</div><div>./otp_build boot</div><div><br></div><div>The build failure looks like this:</div>


<div><div>gcc †-g †-O3 -fomit-frame-pointer -I/home/wiley/build/erlang2/test2/otp_src_R15B01/erts/armv7l-unknown-linux-gnu †-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -fno-tree-copyrename †-D_GNU_SOURCE -DERTS_SMP -DHAVE_CONFIG_H -Wall -Wstrict-prototypes -Wmissing-prototypes -Wdeclaration-after-statement -DUSE_THREADS -D_THREAD_SAFE -D_REENTRANT -DPOSIX_THREADS -D_POSIX_THREAD_SAFE_FUNCTIONS †-Iarmv7l-unknown-linux-gnu/opt/smp -Ibeam -Isys/unix -Isys/common -Iarmv7l-unknown-linux-gnu -Izlib †-Ipcre -Ihipe -I../include -I../include/armv7l-unknown-linux-gnu -I../include/internal -I../include/internal/armv7l-unknown-linux-gnu -c beam/erl_bif_info.c -o obj/armv7l-unknown-linux-gnu/opt/smp/erl_bif_info.o</div>


<div>beam/erl_bif_info.c: In function ‚system_info_1‚:</div><div>beam/erl_bif_info.c:2133:2: error: ‚am_arm‚ undeclared (first use in this function)</div><div>beam/erl_bif_info.c:2133:2: note: each undeclared identifier is reported only once for each function it appears in</div>


<div>make[3]: *** [obj/armv7l-unknown-linux-gnu/opt/smp/erl_bif_info.o] Error 1</div><div>make[3]: Leaving directory `/home/wiley/build/erlang2/test2/otp_src_R15B01/erts/emulator'</div><div>make[2]: *** [opt] Error 2</div>


<div>make[2]: Leaving directory `/home/wiley/build/erlang2/test2/otp_src_R15B01/erts/emulator'</div><div>make[1]: *** [smp] Error 2</div><div>make[1]: Leaving directory `/home/wiley/build/erlang2/test2/otp_src_R15B01/erts'</div>


<div>make: *** [emulator] Error 2</div></div><div><br></div><div>It looks like am_x86 is declared in erts/emulator/armv7l-unknown-linux-gnu/erl_atom_table.h; should am_arm be in there as well?</div><div>I'm not sure what else would be helpful to diagnose this, but here's `uname -a`:</div>


<div>Linux tseng 3.2.1-1-ARCH #1 SMP PREEMPT Sun Jan 22 06:37:13 UTC 2012 armv7l ARMv7 Processor rev 0 (v7l) trimslice GNU/Linux</div><div><br></div><div>Thanks,</div><div>Andrew</div>
</blockquote></div><br><div>Just saw†<a href="http://erlang.org/pipermail/erlang-bugs/2006-December/000268.html">http://erlang.org/pipermail/erlang-bugs/2006-December/000268.html</a>†and it looks like I'm having the same issue. Are there any plans to try to fix <a href="http://configure.in">configure.in</a> so that ARM builds like this either work or produce an error?</div>