<p>Can you build Erlang with Hipe disabled, perhaps?<br>
I don't know if you're planning on using Hipe, of course, but that component appears to be the stumbling block for the build process.</p>
<div class="gmail_quote">Den 12/04/2012 15.15 skrev "Mike Kimber" <<a href="mailto:mkimber@kana.com">mkimber@kana.com</a>>:<br type="attribution"><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">









<div lang="EN-GB" link="blue" vlink="purple">

<div>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">Iím trying to build Erlang R15B01 on Centos 5.8. I
have done this twice before as a root user on two other servers with out issue.
However on this production server I have to use sudo and when I run sudo make I
get the following error:<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial"><u></u>†<u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">=== Entering application hipe<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make[3]: Entering directory
`/home/kana/Downloads/otp_src_R15B01/lib/hipe/rtl'<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">(cd ../main && make hipe.hrl)<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make[4]: Entering directory
`/home/kana/Downloads/otp_src_R15B01/lib/hipe/main'<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">sed -e "s;%VSN%;3.9.1;"
../../hipe/main/hipe.hrl.src > ../../hipe/main/hipe.hrl<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make[4]: Leaving directory
`/home/kana/Downloads/otp_src_R15B01/lib/hipe/main'<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">erlc -W† +debug_info +inline -o../ebin hipe_rtl.erl<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">pthread/ethr_event.c:98: Fatal error in wait__(): Function
not implemented (38)<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make[3]: *** [../ebin/hipe_rtl.beam] Aborted<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make[3]: Leaving directory
`/home/kana/Downloads/otp_src_R15B01/lib/hipe/rtl'<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make[2]: *** [opt] Error 2<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make[2]: Leaving directory
`/home/kana/Downloads/otp_src_R15B01/lib/hipe'<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make[1]: *** [opt] Error 2<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make[1]: Leaving directory
`/home/kana/Downloads/otp_src_R15B01/lib'<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">make: *** [secondary_bootstrap_build] Error 2<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial"><u></u>†<u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial"><u></u>†<u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">Any one have any ideas of why Iím getting the above? Iíve
googled and the main work aroundís seem to be trying different released of
Erlang, which as I have already proved it cane b installed on Centos 5.8 Iíd
rather not have to go back and downgrade my other servers.<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial"><u></u>†<u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">Thanks<u></u><u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial"><u></u>†<u></u></span></font></p>

<p class="MsoNormal"><font face="Arial"><span style="font-size:10.0pt;font-family:Arial">Mike <u></u><u></u></span></font></p>

</div>

</div>


<br>_______________________________________________<br>
erlang-questions mailing list<br>
<a href="mailto:erlang-questions@erlang.org">erlang-questions@erlang.org</a><br>
<a href="http://erlang.org/mailman/listinfo/erlang-questions" target="_blank">http://erlang.org/mailman/listinfo/erlang-questions</a><br>
<br></blockquote></div>