[erlang-questions] Problem building plt to dialyzer

Michel Boaventura <>
Mon Jan 16 04:29:34 CET 2017


Hi,

I've installed erlang 19.2 from source code on my Gentoo Linux and I'm not
able to build plt to dialyzer. It gives me the above error. The build was
configured with --without-javac --prefix=/usr

dialyzer --build_plt --apps kernel

dialyzer: Could not get abstract code for file:
/usr/lib/erlang/lib/kernel-5.1.1/ebin/disk_log.beam (please recompile it
with +debug_info)

I've also tried entering on erts/emulator and running make debug and tried
to set ERL_COMPILE_FLAGS="+debug_info" with no luck.

I don't know if it is an issue with gentoo (both my gentoo machines have
the same problem) because I have the same issue using portage and evm to
install it.

Thank you!

-- 
Michel Almada de Castro Boaventura
Analista de Sistemas
Laboratório de Software Livre - LSL
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20170116/6d5b2792/attachment.html>


More information about the erlang-questions mailing list