[erlang-questions] lib/syntax_tools uses LGPL-2.0 + license

Kenneth Lundin <>
Fri Feb 10 09:02:25 CET 2017


Hi,

The license of Syntax tools is changed to Apache-2 and LGPL (it is the
users choice) in the master branch (which is the way to
the next major release (OTP 20) in end of June.

And yes you can leave out syntax tools for most usage. It is mostly used
during development for some non mandatory tools.
For example it is used by edoc the tool for generating documentation from
the source code.

It is unlikely to be used in a deployed server.

/Kenneth, Erlang/OTP Ericsson

On Thu, Feb 9, 2017 at 10:25 PM, chris casilli <
> wrote:

> Hello,
>
> I noticed that lib/syntax_tools uses LGPL-2.0+ license.
> How does this effect the overall Apache-2.0 license of OTP.
>
> Can this component be left out. Is a different version available that uses
> Apache-2.0 license.
>
> Kind Regards,
>
> Chris Casilli
>
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20170210/ea88078b/attachment.html>


More information about the erlang-questions mailing list