[erlang-questions] Patch package OTP 19.1.5 released

Hans Nilsson R <>
Wed Oct 26 18:00:21 CEST 2016


There are no such plans afaik.  However, if you take a 19.1 Windows
release and replace the lib/ssh with lib/ssh from the OTP-19.1.5 tag on
github you get the functionality (but you must compile the .erl to .beam
yourself).

Disclaimer: you will not have an official otp-release this way, but for
non-production code it could be ok. I'll take no responsibility :)

-Hans

On 10/26/2016 03:16 PM, József Bérces wrote:
> Is there any plan to compile it for windows and share it on erlang.org?
> 
> Thanks,
> Jozsef
> 
> -----Original Message-----
> From:  [mailto:] On Behalf Of Hans Nilsson R
> Sent: Tuesday, October 18, 2016 11:06
> To: 
> Subject: [erlang-questions] Patch package OTP 19.1.5 released
> 
> Patch Package:           OTP 19.1.5
> Git Tag:                 OTP-19.1.5
> Date:                    2016-10-18
> Trouble Report Id:       OTP-13972
> Seq num:
> System:                  OTP
> Release:                 19
> Application:             ssh-4.3.6
> Predecessor:             OTP 19.1.4
> 
>  Check out the git tag OTP-19.1.5, and build a full OTP system  including documentation. Apply one or more applications from this  build as patches to your installation using the 'otp_patch_apply'
>  tool. For information on install requirements, see descriptions for  each application version below.
> 
>  ---------------------------------------------------------------------
>  --- ssh-4.3.6 -------------------------------------------------------
>  ---------------------------------------------------------------------
> 
>  Note! The ssh-4.3.6 application can *not* be applied independently of
>        other applications on an arbitrary OTP 19 installation.
> 
>        On a full OTP 19 installation, also the following runtime
>        dependency has to be satisfied:
>        -- stdlib-3.1 (first satisfied in OTP 19.1)
> 
> 
>  --- Fixed Bugs and Malfunctions ---
> 
>   OTP-13972    Application(s): ssh
> 
>                Re-negotiation problems with OpenSSH client solved.
> 
> 
>  Full runtime dependencies of ssh-4.3.6: crypto-3.3, erts-6.0,  kernel-3.0, public_key-1.1, stdlib-3.1
> 
> 
>  ---------------------------------------------------------------------
>  ---------------------------------------------------------------------
>  ---------------------------------------------------------------------
> 
> 
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions
> 

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 4101 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20161026/1e2d95f2/attachment.bin>


More information about the erlang-questions mailing list