[erlang-questions] erl -name foo and hostname

Boris Mühmer <>
Wed May 25 17:51:36 CEST 2016


Have You tried to ping "kazootest2.localdomain"?
It would be interesting which IP shows up, if any at all. Maybe this gives
a hint.
Did You also have a look at "/etc/networks"?


Regards,
Boris


2016-05-25 17:30 GMT+02:00 Dmitry <>:

> ps aux | grep ava
> root     16011  0.0  0.0 103308   852 pts/0    S+   09:20   0:00 grep ava
> [ ~]#
>
> no The AVAHI daemon is not running.
>
>
> On Wednesday, May 25, 2016 8:11 PM, Boris Mühmer <>
> wrote:
>
>
> Do You happen to have the "avahi" daemon running?
>
>
> Regards,
> Boris
>
> 2016-05-25 15:53 GMT+02:00 Dmitry <>:
>
> Hi
>
> here is my data:
>
> [ ~]# hostname
> kazootest2.mydomain.local
> [ ~]# hostname -f
> kazootest2.mydomain.local
> [ ~]# erl -name foo
> Erlang R15B03 (erts-5.9.3.1) [source] [64-bit] [async-threads:0] [hipe]
> [kernel-poll:false]
>
> Eshell V5.9.3.1  (abort with ^G)
> ()1>
>
>
>
>
> On Monday, May 23, 2016 3:10 PM, Dmitry <> wrote:
>
>
> Hi
>
>  cat /etc/hosts
> 127.0.0.1               localhost.localdomain localhost
> ::1             localhost6.localdomain6 localhost6
> 192.168.175.135   kazootest2.mydomain.local kazootest2
>
> [ ~]# cat /etc/sysconfig/network
> NETWORKING=yes
> NETWORKING_IPV6=no
> HOSTNAME=kazootest2.mydomain.local
>
> [ ~]# erl -name foo
> Erlang R15B03 (erts-5.9.3.1) [source] [64-bit] [async-threads:0] [hipe]
> [kernel-poll:false]
>
> Eshell V5.9.3.1  (abort with ^G)
> ()1>
>
>
> Why dous it shows kazootest2.localdomain?
>
> Any help appreciated
>
>
>
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions
>
>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20160525/e3b9d9f1/attachment.html>


More information about the erlang-questions mailing list