[erlang-questions] 19.0 vs wx on a mac

Felix Gallo <>
Sun Jul 3 07:44:30 CEST 2016


With a bog standard wx 3.0 installation that had worked for the 17 and 18
series on a mac and hadn't changed for about a year, I was able to compile
a wx-aware 19.0, but running observer caused obscure wx crashes when I
clicked on any buttons.

I figured maybe, since the release notes mention wx 3.1, that the
HOWTO/INSTALL.md doc hadn't been updated, and so I tried to install wx
3.1.0 and compile with that.  However, the wx application refuses to
compile, because in its config.log we see:

conftest.cc:54:33: error: no matching constructor for initialization of
'wxGLCanvas'
                           wxGLCanvas * bar = new wxGLCanvas((wxWindow *)
NULL, -1,
                                                  ^
 ~~~~~~~~~~~~~~~~~~~~~~
/usr/local/include/wx-3.1/wx/osx/glcanvas.h:69:5: note: candidate
constructor not viable: no known conversion from 'const wxPoint' to 'const
int *' for 3rd argument
    wxGLCanvas(wxWindow *parent,
    ^
/usr/local/include/wx-3.1/wx/osx/glcanvas.h:60:5: note: candidate
constructor not viable: no known conversion from 'int' to 'const
wxGLAttributes' for 2nd argument
...

which results in a failure to link, and so wx is skipped.

That looks like the configure script is not wx-3.1 aware or something of
that nature, so I'm now backpedalling to 3.0.0.

Is anyone aware of the proper combination of sigils, incantations, and
cargo cult mumbo jumbo necessary to properly compile a wx-aware 19.0 on a
mac in such a way that the resulting wx doesn't crash?

F.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20160702/9f0f3f3b/attachment.html>


More information about the erlang-questions mailing list