[erlang-questions] Erlang/OTP 17.0 on android

Gustav Spellauge <>
Wed Jan 27 12:41:08 CET 2016


good morning,

please allow me to ask a (maybe superfluous) question.

i installed http://erlang.ernovation.com/files/Erlang4Android17.0.apk on 
my android device (SM-G901F) running cyanogenmod 
12-20150418-UNOFFICIAL-kccat6xx, android version 5.0.2.

when starting by typing 
./data/data/com.ernovation.erlangforandroid/files/erlang/bin/erl into a 
command shell, the response is:

error: only position independent executables (PIE) are supported.
Eshell V6.0  (abort with ^G)
1>

and the system seems to be running.

question: what about the pie related error message? can it be safely 
ignored? if no, what can i do to get rid of it (and the underlying 
problem of course)?

thanks in advance for your answer.

g.


More information about the erlang-questions mailing list