[erlang-questions] snmpm:register_agent/3 suddenly stopped working!

jim rosenblum <>
Wed Feb 11 04:40:37 CET 2015


Folks,

I have an application that uses snmp that used to work and all of a sudden
doesn't - I did upgrade from 17.1 to 17.4 - but other than that nothing has
changed that I know of. I am having trouble down-grading, so I cannot
confirm that the upgrade is the culprit.

When I do the following from a machine with IP address 10.6.81.19
1> snmpm:register_agent(hope,"Hope", [{engine_id,
"mgrEngine"},{community,"CLSENTRY"},{address, "10.7.42.11"}]).

I get
{error,{bad_address,{snmpUDPDomain,"10.7.42.11"}}}

I have an appropriate snmpd.conf on 10.7.42.11 that has

com2sec sentrysrv 10.6.81.19/32 CLSENTRY
group CLROGroup v2c sentrysrv
view all included .1 80
access CLROGroup "" v2c noauth exact all none none

adding {tdomain, transportDomainUdpIpv4} to the option list results in the,
essentially, same error:
{error,{bad_address,{{error,{bad_address,{transportDomainUdpIpv4,"10.7.42.11"}}}


Both machines can ping each other. The snmpd daemon is running on .11, I
have tried all kinds of additional options (port, etc.), but cannot get it
to work

This is *killing* me, can anyone point out what stupid thing I am doing
wrong?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20150210/61f59080/attachment.html>


More information about the erlang-questions mailing list