[erlang-questions] Can't attach to a running release: "No such device or address"

Ivan Uemlianin ivan@REDACTED
Mon Jun 23 15:13:16 CEST 2014

Dear All

I have an erlang release (packaged using rebar) running on a server. 
After a bit of maintenance and stopping and starting, I notice I can't 
attach to the running release:

   $ ./bin/appnode attach
   No running Erlang on pipe /tmp/path/to/erlang.pipe.123: No such 
device or address

The pipe directory exists, containing files erlang.pipe.123.r and 
erlang.pipe.123.w.  File permissions look ok.  I can ping the node.  The 
release is running normally.

I have tried

   $./erts- /tmp/path/to/erlang.pipe.123

and that has the same result. (the version of erts is quite old).

I have googled around the interwebs.

Can anyone suggset some ideas for why this is happening and, mainly, how 
I can attach?

With thanks and best wishes


Ivan A. Uemlianin PhD
Speech Technology Research and Development


                         festina lente

More information about the erlang-questions mailing list