[erlang-questions] "erlang-src" package upgrade breaks "syntax_tools" and rebar builds

Karolis Petrauskas <>
Tue Feb 4 12:47:56 CET 2014


Hello,

I still have problems using erlang package provided by esl. I am using
Kubuntu 13.10 and have the following line in
/etc/apt/sources.list.d/erlang-solutions.list:

    deb http://binaries.erlang-solutions.com/debian saucy contrib

When running `sudo apt-get install erlang-src` I'm getting:

    The following packages have unmet dependencies:
     erlang-src : Depends: erlang-base (>= 1:16.b.3-3) but 1:16.b.3 is
to be installed or
                           erlang-base-hipe (>= 1:16.b.3-3)

The command `sudo apt-get install --reinstall erlang-base` installs
"erlang-base 1:16.b.3".

I have cleaned by apt cache and updated the apt sources.

Karolis

On Mon, Feb 3, 2014 at 2:44 PM, Karol Urbanski
<> wrote:
> On Sat, Feb 01, 2014 at 02:27:22PM +0000, Roger Lipscombe wrote:
>> "The esl-erlang package is a file containg the complete installation:
>> it includes the Erlang/OTP platform and all of its applications. The
>> erlang package is a frontend to a number of smaller packages.
>> Currently we support both erlang and esl-erlang."
>>
>> I've just done another "apt-get update; apt-get upgrade", and there's
>> a whole heap of new packages (1:16.b.3-3), which appear to have fixed
>> the problem; so it looks like I got caught mid-push, or the version
>> number got messed up earlier.
>>
>> Either way, it all seems good now.
>>
>> Thanks,
>> Roger.
>
> Hi,
>
> we had a small mixup with the version numbers due to rushing the patch
> release. I'm glad to hear it works fine now, and sorry for the
> inconvenience!
>
> Best regards,
> Karol Urbanski
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions



More information about the erlang-questions mailing list