[erlang-questions] wx debugger not working now

Eric Pailleau <>
Sun Dec 7 10:34:03 CET 2014


Hi Dan,
BTW, is there any plan to move debugger in Observer ?
regards

« Envoyé depuis mon mobile » Eric

Dan Gudmundsson <> a écrit :

>Seems I broke something when I removed the gs code from debugger.
>
>ia and iaa calls dbg_ui_trace which is removed from the code base now.
>
>Does the debugger window start at all?
>i.e. does im(), debugger:start() work?
>
>Will dig more to tomorrow.
>
>On Sun, Dec 7, 2014 at 5:13 AM, Wes James <> wrote:
>
>> Thanks for checking.  I installed wx 3 per these instructions:
>>
>> http://codelite.org/LiteEditor/WxWidgets30Binaries#toc2
>>
>> and ran:
>>
>> $> wx-config --version-full
>> 3.0.2.0
>>
>> ran make clean and make and make install and still got the error.  I
>> apt-get purge'd the wx2.8 stuff I had just so it was not there.  Did make
>> clean, make and make install and I still get the error :(
>>
>> Any idea why (otp devs)?
>>
>> Thanks,
>>
>> -wes
>>
>>
>>
>> On Sat, Dec 6, 2014 at 5:29 PM, PAILLEAU Eric <>
>> wrote:
>>
>>> Hi,
>>>
>>> I get same error on Kubuntu (Ubuntu 14.04.1 LTS) i686
>>> with :
>>> $> cat /usr/lib/erlang/releases/RELEASES
>>> [{release,"Erlang/OTP","17","6.2",
>>>           [{kernel,"3.0.3","/usr/lib/erlang/lib/kernel-3.0.3"},
>>>            {stdlib,"2.2","/usr/lib/erlang/lib/stdlib-2.2"},
>>>            {sasl,"2.4.1","/usr/lib/erlang/lib/sasl-2.4.1"}],
>>>           permanent}].
>>>
>>> $> grep -rl dbg_ui_trace /usr/lib/erlang/lib
>>> /usr/lib/erlang/lib/debugger-4.0.1/ebin/dbg_wx_mon.beam
>>> /usr/lib/erlang/lib/debugger-4.0.1/src/i.erl
>>> /usr/lib/erlang/lib/debugger-4.0.1/src/dbg_wx_mon.erl
>>>
>>> looks linked to wx in debugger.
>>>
>>> $> wx-config --version-full
>>> 2.8.12.1
>>>
>>> It is maybe due to a WX 3.0 driver feature used. But OTP team may better
>>> answer on this.
>>>
>>> Regards
>>>
>>> _______________________________________________
>>> erlang-questions mailing list
>>> 
>>> http://erlang.org/mailman/listinfo/erlang-questions
>>>
>>
>>
>> _______________________________________________
>> erlang-questions mailing list
>> 
>> http://erlang.org/mailman/listinfo/erlang-questions
>>
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20141207/456c57a3/attachment.html>


More information about the erlang-questions mailing list