[erlang-questions] R16B asn1rt_nif error

Kenneth Lundin <>
Tue Mar 12 17:45:43 CET 2013


hi Andrei,

from the crash info it seems that you don't have the module asn1rt_nif
properly loaded.
This module exports 3 so called Nifs (functions implemented in C)
a .so file is supposed to be automatically loaded when the asn1rt_nif
module is loaded.
you can try calling asn1rt_nif:decode_ber_tlv(<<0,0>>) on your system.

If this fails you have an unhealty system (the .so file under
lib/asn1-x.y/priv is missing or corrupt or can't be loaded for some reason.

If this is the case you will have problems with all attempts to decode
ASN.1 encoded data using the BER/DER encoding rules, which are the ones
used for certificates and other SSL/TLS related stuff.

This can be the causebof the other SSL problem you reported on R16B as well.

In R15B I think there was a fallback that would run pure Erlang code if the
asn1rt_nif module failed to be loaded. This is no longer the case.

/Kenneth, Erlang/OTP Ericsson
Den 11 mar 2013 22:52 skrev "Andrei Soroker" <>:

> Hello,
>
> I just upgraded from R15B03 to R16B and I'm seeing the following:
>
> {{keyfile,{badmatch,{error,{asn1,{undef,[{asn1rt_nif,decode_ber_tlv,[<<
> ...
>
> {'OTP-PUB-KEY',decode,2,[{file,"OTP-PUB-KEY.erl"},{line,985}]},{public_key,der_decode,2,[{file,"public_key.erl"},{line,169}]},{ssl_connection,init_private_key,5,[{file,"ssl_connection.erl"},{line,1176}]},{ssl_connection,ssl_init,2,[{file,"ssl_connection.erl"},{line,1115}]},{ssl_connection,init,1,[{file,"ssl_connection.erl"},{line,303}]}
>
> Is there some quick fix that I'm missing?
>
> Thanks!
> Andrei
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20130312/744f263b/attachment.html>


More information about the erlang-questions mailing list