[erlang-questions] EPEL Erlang RPM dependencies

Matt McClure <>
Wed Sep 5 15:30:39 CEST 2012


I just enabled the EPEL erlang repo
<http://repos.fedorapeople.org/repos/peter/erlang/epel-$releasever/$basearch/>
and I was suprised to see the next `yum -y upgrade` install a slew of
audio and video related packages. It looks like erlang-wx and possibly
others require them, and that erlang requires all of the erlang-*
packages. Is there a way to install a leaner erlang via the RPMs?

Thanks,
Matt

***

[ rabbitmq]# rpm -e libtheora
error: Failed dependencies:
        libtheora.so.0()(64bit) is needed by (installed)
gstreamer-plugins-base-0.10.20-3.0.1.el5_3.x86_64
        libtheora.so.0(libtheora.so.1.0)(64bit) is needed by
(installed) gstreamer-plugins-base-0.10.20-3.0.1.el5_3.x86_64
[ rabbitmq]# rpm -e gstreamer
error: Failed dependencies:
        libgstbase-0.10.so.0()(64bit) is needed by (installed)
gstreamer-plugins-base-0.10.20-3.0.1.el5_3.x86_64
        libgstcontroller-0.10.so.0()(64bit) is needed by (installed)
gstreamer-plugins-base-0.10.20-3.0.1.el5_3.x86_64
        libgstdataprotocol-0.10.so.0()(64bit) is needed by (installed)
gstreamer-plugins-base-0.10.20-3.0.1.el5_3.x86_64
        libgstreamer-0.10.so.0()(64bit) is needed by (installed)
gstreamer-plugins-base-0.10.20-3.0.1.el5_3.x86_64
        libgstreamer-0.10.so.0()(64bit) is needed by (installed)
wxGTK-2.8.12-1.el5.x86_64
        gstreamer >= 0.10.20 is needed by (installed)
gstreamer-plugins-base-0.10.20-3.0.1.el5_3.x86_64
[ rabbitmq]# rpm -e wxGTK
error: Failed dependencies:
        libwx_gtk2u_adv-2.8.so.0()(64bit) is needed by (installed)
erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_adv-2.8.so.0(WXU_2.8)(64bit) is needed by
(installed) erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_aui-2.8.so.0()(64bit) is needed by (installed)
erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_aui-2.8.so.0(WXU_2.8)(64bit) is needed by
(installed) erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_aui-2.8.so.0(WXU_2.8.5)(64bit) is needed by
(installed) erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_core-2.8.so.0()(64bit) is needed by (installed)
wxGTK-gl-2.8.12-1.el5.x86_64
        libwx_gtk2u_core-2.8.so.0()(64bit) is needed by (installed)
erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) is needed by
(installed) wxGTK-gl-2.8.12-1.el5.x86_64
        libwx_gtk2u_core-2.8.so.0(WXU_2.8)(64bit) is needed by
(installed) erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_html-2.8.so.0()(64bit) is needed by (installed)
erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_html-2.8.so.0(WXU_2.8)(64bit) is needed by
(installed) erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_stc-2.8.so.0()(64bit) is needed by (installed)
erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_stc-2.8.so.0(WXU_2.8)(64bit) is needed by
(installed) erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_xrc-2.8.so.0()(64bit) is needed by (installed)
erlang-wx-R14B-04.1.el5.x86_64
        libwx_gtk2u_xrc-2.8.so.0(WXU_2.8)(64bit) is needed by
(installed) erlang-wx-R14B-04.1.el5.x86_64
        wxGTK = 2.8.12-1.el5 is needed by (installed)
wxGTK-gl-2.8.12-1.el5.x86_64

-- 
Matt McClure
http://www.matthewlmcclure.com
http://www.mapmyfitness.com/profile/matthewlmcclure



More information about the erlang-questions mailing list