[erlang-questions] erl using 99% CPU while idle

Alessandro Sivieri <>
Thu Mar 29 09:27:21 CEST 2012


On Tue, Mar 27, 2012 at 3:37 PM, Frank Hunleth <
> wrote:

> I was wondering if anyone had seen erl, specifically the
> erts-5.9/bin/beam process, run at 99% CPU while at the shell prompt.
> All that I do is run erl without any command line arguments and let it
> sit. This is a cross-compiled Erlang R15B running on an ARM processor,
> so it could be the case that I messed up an option somewhere along the
> line. FWIW, the processing must be trivial since the system feels
> completely responsive and Erlang applications appear to run fine. I
> ran strace to see what was going on and the following lines repeat:
>
>
The same thing happen on MIPS microprocessors, and it is solved by not
specifying the --disable-threads option. Thanks for having solved this.

-- 
Sivieri Alessandro

http://sivieri.wordpress.com/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20120329/ab4373e2/attachment.html>


More information about the erlang-questions mailing list