[erlang-questions] beginner: How make reltool handle multiple versions of libs?

Bengt Kleberg <>
Thu Feb 9 14:53:50 CET 2012


Greetings,

The Erlang/OTP installation I use(*) overwhelms reltool(**). At least
that is what I think, since dialyzer gave me a similar error until I
switched to use "-r lib/*-0".
Can I tell reltool to ignore all but the *-0 versions, too?


bengt

(*)
lib/appmon-0
lib/appmon-2.1.12
lib/appmon-2.1.13
lib/asn1-0
lib/asn1-1.6.14
lib/asn1-1.6.14.1
lib/asn1-1.6.15
lib/asn1-1.6.16
...
lib/wx-0.98.8
lib/wx-0.98.9
lib/wx-0.99
lib/xmerl-0
lib/xmerl-1.2.10
lib/xmerl-1.2.5
lib/xmerl-1.2.6
lib/xmerl-1.2.7
lib/xmerl-1.2.8
lib/xmerl-1.2.9


(**)
4> {ok, Pid} = reltool:start_server([{config, "reltool.config"}]).
{ok,<0.51.0>}
   
=CRASH REPORT==== 9-Feb-2012::14:43:17 ===
  crasher:
    initial call: reltool_server:init/1
    pid: <0.51.0>
    registered_name: []
    exception exit: "hipe: Application version clash. Multiple
directories contains version \"3.8.1\"."
      in function  reltool_server:do_init/1
      in call from reltool_server:init/1
    ancestors: [<0.47.0>]
    messages: []
    links: [<0.47.0>]
    dictionary: []
    trap_exit: false
    status: running
    heap_size: 317811
    stack_size: 24
    reductions: 1762187
  neighbours:
    neighbour: [{pid,<0.47.0>},
                  {registered_name,[]},
                  {initial_call,{erlang,apply,2}},
                  {current_function,{shell,eval_loop,3}},
                  {ancestors,[]},
                  {messages,[]},
                  {links,[<0.26.0>,<0.51.0>]},
                  {dictionary,[]},
                  {trap_exit,false},
                  {status,waiting},
                  {heap_size,2584},
                  {stack_size,7},
                  {reductions,5367}]
** exception error: "hipe: Application version clash. Multiple
directories contains version \"3.8.1\"."





More information about the erlang-questions mailing list