[erlang-questions] erlsrv fails with boot error when using argument "-run application start <appname>"

Art Beall <>
Fri Apr 20 14:14:04 CEST 2012


Hello,
 
Thanks in advance for any help for an erlang newbie.
 
We've developed an erlang application using OTP. It receives tcp messages, stores the data in ets, and provides a simple http api for returing the data as a JSON object. 
 
It works just fine undef werl. We are testing under windows 7. 
 
But when we use the erlsrv command to create/start the application is dies with an init error, terminating in do_boot. I've tried with both boot files, the start_clean and start_sasl, using a debug log file. 
 
We've tried various combos of options and arguments. eunit tests will run under the service, normal functions will run. But anything having to do with OTP seems to fail.
 
Any help would be appreciated!
 
Thanks

Art
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20120420/cd50768d/attachment.html>


More information about the erlang-questions mailing list