[erlang-questions] Make failing on Centos 5.8 for R15B01

Mike Kimber <>
Thu Apr 12 15:15:10 CEST 2012


I'm trying to build Erlang R15B01 on Centos 5.8. I have done this twice before as a root user on two other servers with out issue. However on this production server I have to use sudo and when I run sudo make I get the following error:

=== Entering application hipe
make[3]: Entering directory `/home/kana/Downloads/otp_src_R15B01/lib/hipe/rtl'
(cd ../main && make hipe.hrl)
make[4]: Entering directory `/home/kana/Downloads/otp_src_R15B01/lib/hipe/main'
sed -e "s;%VSN%;3.9.1;" ../../hipe/main/hipe.hrl.src > ../../hipe/main/hipe.hrl
make[4]: Leaving directory `/home/kana/Downloads/otp_src_R15B01/lib/hipe/main'
erlc -W  +debug_info +inline -o../ebin hipe_rtl.erl
pthread/ethr_event.c:98: Fatal error in wait__(): Function not implemented (38)
make[3]: *** [../ebin/hipe_rtl.beam] Aborted
make[3]: Leaving directory `/home/kana/Downloads/otp_src_R15B01/lib/hipe/rtl'
make[2]: *** [opt] Error 2
make[2]: Leaving directory `/home/kana/Downloads/otp_src_R15B01/lib/hipe'
make[1]: *** [opt] Error 2
make[1]: Leaving directory `/home/kana/Downloads/otp_src_R15B01/lib'
make: *** [secondary_bootstrap_build] Error 2


Any one have any ideas of why I'm getting the above? I've googled and the main work around's seem to be trying different released of Erlang, which as I have already proved it cane b installed on Centos 5.8 I'd rather not have to go back and downgrade my other servers.

Thanks

Mike
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20120412/fc202894/attachment.html>


More information about the erlang-questions mailing list