[erlang-questions] noproc file_server_2 when trying to load boot file

Tristan Sloughter <>
Sat Oct 22 17:21:43 CEST 2011


Though I can point out I actually have no file_server_2...

find ~/otp/ -name *file_server*
/home/dotcloud/otp/lib/kernel-2.14.4/src/file_server.erl
/home/dotcloud/otp/lib/kernel-2.14.4/ebin/file_server.beam
/home/dotcloud/otp/lib/kernel-2.14.5/src/file_server.erl
/home/dotcloud/otp/lib/kernel-2.14.5/ebin/file_server.beam

Hmm..

2011/10/22 Tristan Sloughter <>

> Right, there isn't much I can do in that respect though since I can't get
> into a shell when loading the boot file.
>
> Thanks,
> Tristan
>
>
> 2011/10/22 Motiejus Jakštys <>
>
>> On Sat, Oct 22, 2011 at 10:11:39AM -0500, Tristan Sloughter wrote:
>> > I have a .rel file and successfully create the boot/script files with
>> > systools:make_script but when I try to load the boot file it crashes
>> with an
>> > error I can't find reference too anywhere online. Does anyone have an
>> idea
>> > on what might be wrong?
>> >
>> > $ erl
>> > Erlang R14B04 (erts-5.8.5) [source] [64-bit] [smp:4:4] [rq:4]
>> > [async-threads:0] [kernel-poll:false]
>> >
>> > Eshell V5.8.5  (abort with ^G)
>> > 1> systools:make_script("ctdemo", [local]).
>> > ok
>> > 2> q().
>> > ok
>> >
>> > $ erl -boot ctdemo
>> > {"init terminating in
>> >
>> do_boot",{noproc,{gen_server,call,[file_server_2,{open,"./.erlang",[read]},infinity]}}}
>>
>> In a nutshell, gen_server is complaining that process file_server_2 is
>> not running.
>>
>> Check application:loaded_applications(), global_registered_names(),
>> appmon:start() for troubleshooting.
>>
>> Hope this helps
>>
>> Motiejus
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20111022/c27e8289/attachment.html>


More information about the erlang-questions mailing list