[erlang-questions] exmpp and rebar

Max Bourinov <>
Wed Nov 2 11:20:25 CET 2011


Maxim, I have another question,

even everything is running and all services are connected to XMPP I see the
following error messages in my console when I use exmpp rebarized by you:

=ERROR REPORT==== 2-Nov-2011::13:17:35 ===
Failed to load driver "exmpp_xml_expat_legacy":
dlopen(/Users/bourinov/github/processor/rel/pr1node/lib/exmpp-git-head/priv/lib/exmpp_xml_expat_legacy.so,
2): image not found

=ERROR REPORT==== 2-Nov-2011::13:17:35 ===
Failed to load driver "exmpp_compress_zlib":
dlopen(/Users/bourinov/github/processor/rel/pr1node/lib/exmpp-git-head/priv/lib/exmpp_compress_zlib.so,
2): image not found

Any ideas  what could it be and how to fix it?

Thank you in advance,
Max

On Wed, Nov 2, 2011 at 12:58 PM, Maxim Treskin <> wrote:

> Hello, Max
> Try my rebarized fork of exmpp: git://github.com/Zert/exmpp.git
> Do not use system-wide installation of exmpp, just add this deps in
> rebar.config.
>
> On 2 November 2011 16:55, Paul Oliver <> wrote:
>
>> Yup.  What error were you getting?  I have the following in my
>> rebar.config:
>>
>> {deps, [
>>     {exmpp, ".*", {git,
>> "https://puzza007@github.com/puzza007/exmpp.git", {branch, "master"}}}
>>   ]}.
>>
>> On Wed, Nov 2, 2011 at 9:07 AM, Max Bourinov <> wrote:
>> > Already tried yours :-) Doesn't work somehow...
>> > Did you manage to make it running as a part of bigger rebar-ized app?
>> >
>> >
>> > On Wed, Nov 2, 2011 at 12:03 PM, Paul Oliver <>
>> wrote:
>> >>
>> >> Hi Max,
>> >> I have a quick and dirty rebarised version of exmpp here
>> >> https://github.com/puzza007/exmpp.
>> >> Cheers,Paul.
>> >> On Wed, Nov 2, 2011 at 8:10 AM, CGS <> wrote:
>> >> > You need to include the path toward you exmpp or put exmpp into the
>> >> > Erlang
>> >> > lib standard path. It looks like your application doesn't know from
>> >> > where to
>> >> > take exmpp.
>> >> >
>> >> > Cheers,
>> >> > CGS
>> >> >
>> >> >
>> >> >
>> >> > On 11/02/2011 08:54 AM, Max Bourinov wrote:
>> >> >
>> >> > Hi guys,
>> >> > I have rebar-ized project that uses exmpp library. exmpp library
>> >> > installed
>> >> > in my system (sudo make install).
>> >> > Since there is no properly rebar-ized exmpp I try to run in in my
>> >> > application code manually instead of starting it in processor.app:
>> >> > start(_StartType, _StartArgs) ->
>> >> > ok = application:start(exmpp),
>> >> > processor_sup:start_link().
>> >> > When I test my application (not release) everything work like a
>> charm.
>> >> > But when I do:
>> >> > ./rebar compile
>> >> > ./rebar generate
>> >> > and then run released node I have the following exception:
>> >> > Erlang R14B04 (erts-5.8.5) [source] [smp:2:2] [rq:2]
>> [async-threads:5]
>> >> > [hipe] [kernel-poll:true]
>> >> >
>> >> > =INFO REPORT==== 2-Nov-2011::10:38:08 ===
>> >> >     application: processor
>> >> >     exited: {bad_return,
>> >> >                 {{processor_app,start,[normal,[]]},
>> >> >                  {'EXIT',
>> >> >                      {{badmatch,
>> >> >                           {error,{"no such file or
>> >> > directory","exmpp.app"}}},
>> >> >                       [{processor_app,start,2},
>> >> >                        {application_master,start_it_old,4}]}}}}
>> >> >     type: permanent
>> >> > {"Kernel pid
>> >> >
>> >> >
>> terminated",application_controller,"{application_start_failure,processor,{bad_return,{{processor_app,start,[normal,[]]},{'EXIT',{{badmatch,{error,{[110,111,32,115,117,99,104,32,102,105,108,101,32,111,114,32,100,105,114,101,99,116,111,114,121],[101,120,109,112,112,46,97,112,112]}}},[{processor_app,start,2},{application_master,start_it_old,4}]}}}}}"}
>> >> > Crash dump was written to: erl_crash.dump
>> >> > Kernel pid terminated (application_controller)
>> >> >
>> >> >
>> ({application_start_failure,processor,{bad_return,{{processor_app,start,[normal,[]]},{'EXIT',{{badmatch,{error,{[110,111,32,115,117,99,104,32,102,105,1
>> >> > As I already said this approach doesn't work. Do you have any ideas
>> how
>> >> > to
>> >> > properly configure my app to use exmpp?
>> >> > Best regards,
>> >> > Max
>> >> >
>> >> > _______________________________________________
>> >> > erlang-questions mailing list
>> >> > 
>> >> > http://erlang.org/mailman/listinfo/erlang-questions
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > erlang-questions mailing list
>> >> > 
>> >> > http://erlang.org/mailman/listinfo/erlang-questions
>> >> >
>> >> >
>> >> _______________________________________________
>> >> erlang-questions mailing list
>> >> 
>> >> http://erlang.org/mailman/listinfo/erlang-questions
>> >
>> >
>> _______________________________________________
>> erlang-questions mailing list
>> 
>> http://erlang.org/mailman/listinfo/erlang-questions
>>
>
>
>
> --
> Maxim Treskin
>
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20111102/84437afc/attachment.html>


More information about the erlang-questions mailing list