[erlang-questions] Distributed Erlang on Dotcloud

Tristan Sloughter <>
Tue Nov 1 14:23:58 CET 2011


Thanks Vincent. Yes, I set the names with -sname for a shortname since
attempting -name for a long name crashes the VM, as I mentioned in my email.

And the cookies are set as the same value.

On Tue, Nov 1, 2011 at 5:29 AM, zambal <> wrote:

> Hi Tristan,
>
> I've never attempted to connect Erlang nodes between Dotcloud
> instances, but two things to check (sorry if they're obvious):
>
> - Do you start erl on your vm's with a long name (in the form of
> )
> - Have you set (the same) cookies on both nodes
>
> Vincent
>
> On Nov 1, 2:49 am, Tristan Sloughter <>
> wrote:
> > Has anyone here succeeded, or attempted, to connect Erlang nodes between
> > instances in Dotcloud (https://www.dotcloud.com/)?
> >
> > I can install and run an Erlang node just fine, and I use a custom port
> for
> > epmd because dotcloud requires that. But I can't ping between instances
> of
> > the nodes with the short name and it crashes if you try to start a node
> > with a long name (Can't set long node name! Please check your
> > configuration").
> >
> > Tristan
> >
> > _______________________________________________
> > erlang-questions mailing list
> > ://
> erlang.org/mailman/listinfo/erlang-questions
> _______________________________________________
> erlang-questions mailing list
> 
> http://erlang.org/mailman/listinfo/erlang-questions
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20111101/a4890bc9/attachment.html>


More information about the erlang-questions mailing list