[erlang-questions] SOLVED: Re: Appmon, pman on MacOSX

Ivan Uemlianin <>
Tue May 10 14:50:35 CEST 2011


Dear All

Thanks to everybody for guidance.  I have appmon and pman working now 
(although I haven't done anything with them yet).

Essentially I uninstalled tcl and tk from my MacPorts (this involved 
some fiddling around).  There is another wish on my system, in

     /sw/bin/wish

Presumably this was from fink.  Anyway, it works.

Forgive me if I'm less than enthusiastic about Homebrew.  I'm sure it's 
very nice.  These days I just install everything from source.

Best wishes

Ivan


On 09/05/2011 17:01, Ivan Uemlianin wrote:
> Dear All
>
> I'm running erlang R13B01 on MacOSX.6. I've just tried to launch appmon
> from the erlang shell and got this error (and no appmon):
>
> dyld: Library not loaded: /opt/local/lib/libX11.6.dylib
> Referenced from: /opt/local/bin/wish8.5
> Reason: no suitable image found. Did find:
> /opt/local/lib/libX11.6.dylib: mach-o, but wrong architecture
>
> I've done a quick google but found nothing, so I'm about to go deeper.
>
> In the meantime, has anybody else come up against this and found out how
> to fix it?
>
> With thanks and best wishes
>
> Ivan
>
>


-- 
============================================================
Ivan A. Uemlianin
Speech Technology Research and Development

                     
                      www.llaisdy.com
                          llaisdy.wordpress.com
                      www.linkedin.com/in/ivanuemlianin

     "Froh, froh! Wie seine Sonnen, seine Sonnen fliegen"
                      (Schiller, Beethoven)
============================================================



More information about the erlang-questions mailing list