[erlang-questions] SASL problem

Siri Hansen <>
Thu Jun 30 16:54:55 CEST 2011


Ok, one more shot then - this is pure guessing of course, since I can not
reproduce the problem... You could try to use single quotes around the tuple
and double quotes with no backslash around the string:

... -sasl sasl_error_logger '{file,
"/home/itadm/erlang/log/prototipo_mps_sasl.log"}' ...

I'm not at all an expert on shell scripts and the secrets related to quotes
- there are probably others on this list who are... I'm just giving some
ideas since I have had similar problems myself... hope it helps

/siri

2011/6/30 Carlo Bertoldi <>

> Thanks,
>  but that didn't solved the problem, and the double quotes are still
> missing in the log file, even with the 3 backslashes.
>
>
> On 30/06/2011 16:26, Siri Hansen wrote:
>
>> Hi Carlo!
>>
>> Your script works for me, but it seems from the error report that the
>> double quotes around the log file path have disappeared in your case. You
>> could try to increase the number of backslashes - e.g. to three:
>>
>> ... -sasl sasl_error_logger "{file, \\\"/home/itadm/erlang/log/**prototipo_mps_sasl.log\\\"}"
>> ...
>>
>> Regards
>> /siri
>>
>>
>> 2011/6/30 Carlo Bertoldi < <mailto:
>> carlo.bertoldi@**ubiquity.it <>>>
>>
>>
>>    Hello everybody,
>>     I'm trying to launch my application using heart. This is the
>>    script I'm using:
>>
>>    #!/bin/bash
>>
>>    EBIN_PATH=/home/itadm/**prototipo_mps/ebin
>>    LOG_FILE=/home/itadm/erlang/**log/sonda.log
>>    ERL=/usr/bin/erl
>>    NODE_NAME=sonda
>>
>>    $ERL -sname $NODE_NAME -heart -pa $EBIN_PATH -boot start_sasl
>>    -sasl sasl_error_logger "{file,
>>    \"/home/itadm/erlang/log/**prototipo_mps_sasl.log\"}" -noshell -eval
>>    "application:start(prototipo_**mps)." 2>&1 > $LOG_FILE &
>>
>>
>>    The application starts, but in the log I've got this error, and I
>>    can see that the sasl keeps restarting.
>>
>>
>>    =ERROR REPORT==== 30-Jun-2011::15:36:46 ===
>>    application_controller: syntax error before: '/': {file,
>>    /home/itadm/erlang/log/**prototipo_mps_sasl.log}
>>    {"init terminating in do_boot",{error,'Bad environment variable:
>>    "{file, /home/itadm/erlang/log/**prototipo_mps_sasl.log}"
>>     Application: sasl'}}
>>
>>
>>    =erl_crash_dump:0.1
>>    Thu Jun 30 15:52:32 2011
>>    Slogan: Kernel pid terminated (application_controller)
>>    ({application_start_failure,**kernel,{shutdown,{kernel,**
>> start,[normal,[]]}}})
>>    System version: Erlang R14A (erts-5.8) [source] [64-bit] [smp:4:4]
>>    [rq:4] [async-threads:0] [kernel-poll:false]
>>
>>    If I launch the application using the shell, it works as expected.
>>    Any suggestions?
>>    Thanks,
>>     Carlo
>>
>>    ______________________________**_________________
>>    erlang-questions mailing list
>>     <mailto:erlang-questions@**erlang.org<>
>> >
>>
>>    http://erlang.org/mailman/**listinfo/erlang-questions<http://erlang.org/mailman/listinfo/erlang-questions>
>>
>>
>>
>
> --
> Ubiquity - A little bit forward
> *Carlo Bertoldi*
> Ubiquity
> Via Teodosio 65 -20131, Milano
> Fisso: +39 02 288584.32 - Fax: +39 02 2829795
> Email:  <mailto:carlo.bertoldi@**ubiquity.it<>
> >
> Website: www.ubiquity.it <http://www.ubiquity.it>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20110630/2050a214/attachment.html>


More information about the erlang-questions mailing list