[erlang-questions] Confusing about gproc with global properties

Gregory Haskins gregory.haskins@REDACTED
Fri Apr 15 20:24:48 CEST 2011

Hi Ulf, all,

I am playing around with adding gproc to my edist framework.  I plan on
using it for both a pubsub fabric as well as for end-point management.
I ran into a snag during the integration that I _swear_ worked when I
did some small proof-of-concept work with gproc as stand alone.

That is, it seems any global properties that are registered never end up
showing up.  Consider this:

(controller@REDACTED)2> gproc:reg({p, l, foo}, bar).
(controller@REDACTED)3> gproc:reg({p, g, foo}, bar).
(controller@REDACTED)4> gproc:select([{'_', [], ['$$']}]).

I do not understand why it appears that all global registrations meet a
/dev/null fate.  Any pointers are greatly appreciated.

Note that if I trace gproc_dist, I can see activity during the {p, g, _}
registration, as you would expect.  I started erl with "-gproc
gproc_dist 'all'".  I am using the v0.1.2 branch of esl/gproc
(https://github.com/esl/gproc/tree/v0.1.2), which, IIUC, is the tree Ulf
recommends we use (though now I cannot seem to remember where I got that

Kind Regards,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 267 bytes
Desc: OpenPGP digital signature
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20110415/b32282e0/attachment.bin>

More information about the erlang-questions mailing list