[erlang-questions] SMP active?

Rapsey <>
Fri Aug 6 19:24:22 CEST 2010


If your test program only uses one process for the work that it does, erlang
will only use up one process on the machine.


Sergej

On Fri, Aug 6, 2010 at 6:49 PM, Gardell, Steven <>wrote:

> I am running Erlang on a 4 Core Dell machine:
>
> Linux xxx.sonusnet.com 2.6.9-55.ELsmp #1 SMP Fri Apr 20 16:36:54 EDT
> 2007 x86_64 x86_64 x86_64 GNU/Linux
>
> Erlang R13B04 (erts-5.7.5) [source] [64-bit] [smp:4:4] [rq:4]
> [async-threads:0] [hipe] [kernel-poll:false]
>
> When I run my Erlang program  (a Megaco test program), top shows only
> only one of the cores being used to any meaningful level. Something
> like (5%, 97%, 97%, 97%) idle. Push it harder and, not too surprisingly,
> it starts presenting errors. I have tried the -smp and -S options, but
> there is
> no change in behavior (which is consistent with documentation, since smp
> should
> be enabled by default).
>
> Suggestions? Thanks!
>


More information about the erlang-questions mailing list