[erlang-questions] is inet:gethostbyname( IP ) correct?

info <>
Tue Oct 20 11:33:35 CEST 2009


Dear Raimo,

I uninstalled Comodo and ... the problem disappeared !!!!!!!!!!!!!!!!!!!!!
What else now ?
John

I On Sat, Oct 17, 2009 at 12:46:50AM +0100, info wrote:
> On Fri, Oct 16, 2009 at 04:29:20PM +0200, info wrote:
> I guess Robby wrote:
>  > On Thu, Oct 15, 2009 at 4:28 PM, Raimo Niskanen    <
>  >    <raimo%   >
>  >   > wrote:
>  > 
>  >   > On Thu, Oct 15, 2009 at 03:02:40PM +0200, info wrote:
>  >   >    > Dear Raimo,
>  >   >    > I can resume: I discovered that gethostbyname call inet_gethost.c
>  >   >    > I don't understand inet_gethost.c :-(
>  >   >    > Where "goes" this problem for finding the information ?
>  >   >    > If we know where and what, we could perhaps find what is missing in my
>  >   > windows 2003 ...
>  >   >    > Hope to read you soon !
>  >   >    > John
>  >   >
>  >   > Well, there is not much more to say. inet_gethost.c calls
>  >   > struct hostent *gethostbyname(const char *name) in the
>  >   > winsock2 library:
>  >   >  http://msdn.microsoft.com/en-us/library/ms738524(VS.85).aspx   <http://msdn.microsoft.com/en-us/library/ms738524%28VS.85%29.aspx   >
>  >   > It never returns.
>  >   > It is deprecated but that does not mean broken.
>  >   > I have a Windows 2003 server that it works on.
>  >   > We have not found the reason it differs between
>  >   > my server and your server.
>  >   > And that is about it.
>  >   >
>  >   >
>  >   >
>  > I can consistently reproduce the hanging gethostbyname() in inet_gethost.exe
>  > on Windows 2003 when I have the 'Microsoft Firewall Client for ISA Server
>  > Version 4.0' installed. This is a specific add-on, nothing to do with
>  > Microsoft Firewall in your Network Properties.
>  > 
> 
> I guess info wrote:
>  > but I don't use ISA server !!!
>  > 
> 
> No other interesting firewall software?
> Yes: I am using Comodo.

Can you try to uninstall Comodo and see if the problem disappears.
If so we know where to look for the problem.
(We have installed a 2003 server with Comodo and got no problems,
 other than the possibility to do configuration errors that
 would cause your symptoms)

> 
> I guess Robby wrote:
>  > If I remove it, it works fine, if I add it it hangs. Apart from that the
>  > W2003 build is as vanilla as it gets.
>  > 
>  > Nothing much to go on, but I would not be surprised if some system DLL is
>  > getting in the way. This is very hard to diagnose.
>  > 
>  > One day I'll get around to compiling inet_gethost.exe in my setup, just to
>  > rule out poor linkage due to the VC++ setup used to build the shipping
>  > executables. If I compile up a trivial gethostbyname() example from MSDN, it
>  > works OK in all circumstances.
>  > 
>  > There are a few strange dependencies in other shipped Windows files, for
>  > example beam.dll seems to depend on a particular MSVCR80.DLL with the
>  > version 8.0.50727.1433 . And if you have an older Windows machine, you get
>  > the completely unhelpful popup box telling you that your program could not
>  > be run. This has something to do with Windows Side-by-Side DLL deployment,
>  > and I completely fail to grasp what that's all about.
>  > 
> 
> I guess info wrote:
>  > but I don't have msvcr80.dll !!!
> 
> I guess you do, actually, since Erlang/OTP's installer is supposed
> to install that DLL, if it does not exist already.
> 
> I guess Robby wrote:
>  > 
>  > Robby
> 
> -- 
> 
> / Raimo Niskanen, Erlang/OTP, Ericsson AB

-- 

/ Raimo Niskanen, Erlang/OTP, Ericsson AB


More information about the erlang-questions mailing list