[erlang-questions] Building R13B02-1 on Snow Leopard

Adriano Bonat <>
Fri Oct 2 05:36:01 CEST 2009


On Fri, Oct 2, 2009 at 12:19 AM, jm <> wrote:
> Warning: blind leading the blind here.
>
> I notice that
>
> checking build system type... i386-apple-darwin10.0.0
> checking host system type... i386-apple-darwin10.0.0
>
> What happens if you change the build and systems systems with
>
> System types:
>  --build=BUILD     configure for building on BUILD [guessed]
>  --host=HOST       cross-compile to build programs to run on HOST [BUILD]
>

Just tried appending --build=i686-apple-darwin10 but it continues to
guess "-m32".

> Cant think of a better way of doing this at the moment, but take a look in
> /usr/libexec/gcc/ and see what other systems are listed. eg, on mine
>
> $ ls /usr/libexec/gcc/
> darwin                  i686-apple-darwin8      powerpc-apple-darwin8

:~/Downloads/otp_src_R13B02-1$ ls /usr/libexec/gcc
darwin                 i686-apple-darwin10    powerpc-apple-darwin10

>
> and just for the hell of it see what this produces
>
> $ gcc --dumpmachine
> powerpc-apple-darwin8-gcc-4.0.1: no input files
>

:~/Downloads/otp_src_R13B02-1$ gcc --dumpmachine
i686-apple-darwin10-gcc-4.2.1: no input files


Just tried configure appending --enable-darwin-64bit:
./configure --enable-kernel-poll --enable-threads --enable-smp-support
--enable-hipe --with-ssl=/opt/local --enable-m64-build
--enable-darwin-64bit

and it gives me:
checking for linker flags for loadable drivers... -m64 -m64  -bundle
-flat_namespace -undefined suppress

Now let me `make` :)


More information about the erlang-questions mailing list