[erlang-questions] Is Erlyweb working with Yaws 1.8.1? and other framework questions

Carl McDade <>
Sat May 23 11:57:12 CEST 2009


Yup,

I spent a couple of days going through the archives and only found
that many were having the same problem with the paths producing a
function not found error. I then turned to Yarivs blog and found the
same situation, many with the exact same problem but no answers.

specifically we  all have the same problem as dave who describes it best:



When I follow this instruction, I met some error at the initial step.
I run erlyweb:create_app(”music”, “/home/myid/apps”)., and set the
yaws.conf as follow:

docroot = /home/myid/apps/music/www
appmods =

appname = music

After I run yaws and when i put the url below in my browser, an error
occurred. Here’s the error. What’s the matter??

Internal error, yaws code crashed

ERROR erlang code crashed:
File: appmod:0
Reason: {no_application_data,”Did you forget to call
erlyweb:compile(AppDir) or add the app’s previously compiled .beam
files to the Erlang code path?”}
Req: {http_request,’GET’,{abs_path,”/music”},{1,1}}

p.s. when i put the url as http://localhost:8000/, then it works well.


On Sat, May 23, 2009 at 11:04 AM, Andrew <> wrote:
> I had no problem with Erlyweb on  newest yaws from github. Do you recompile
> your sources and Erlyweb itself? However you may try to ask on Erlyweb
> google group (   http://groups.google.com/group/erlyweb   )
>
> Carl McDade wrote:
>>
>> I tried to get Erlyweb to work with the latest version of Yaws only to
>> find that the problems with appmode (sub paths do cause a fatal error)
>> still exist. Does anyone one know if Yariv is going to continue
>> working on this  or is the project dead?
>>
>> Are there any other erlang frameworks that have MySQL connectivity? I
>> could not find anything.
>>
>>
>
>



-- 
Carl McDade
Content Management Systems Consultant
www.hiveminds.co.uk
________________________



More information about the erlang-questions mailing list