OTP wx driver on OpenSolaris 2009.06

Andrew <>
Wed Jul 22 09:29:56 CEST 2009


Hi all!

Have anybody managed to build latest OTP on latest OpenSolaris (2009.06) 
with latest WxWidgets (2.8.10 built from sources)?
I have "..Can not link wx driver ..." message running OTP configure script.

The wxWidgets built with --with-gtk=2 --with-opengl --disable-shared (it 
seems, OTP wx driver require that), but the problem seems somehow 
connected with '-shared' option of g++ at test of wx driver linking in 
configure script (for lib/wx). Possible some libs are not -fpic, I don't 
know. Any clue how build OTP with wx driver enabled?

Andrew.


More information about the erlang-questions mailing list