Problem with distel debugging / breakpoint

mats cronqvist <>
Mon Jul 13 15:32:14 CEST 2009


Dale Harvey <> writes:

> 2009/7/13 mats cronqvist <>
>
>> Dale Harvey <> writes:
>>
>> > having avoided proper debugging with io statements for to long,
>> > giving the distel debugger a shot.
>> >
>> > following the guide at http://bc.tech.coop/blog/070528.html which
>> > is realy good, however hitting a wall.
>> >
>> > I C-c C-d i to set intepreted, works fine, I press C-x SPC to mark a
>> > breakpoint, fine, I run a function that hits the break point, it stops,
>> > I get am edb window, however when I press RET on the process, I
>> > get the message No buffer for pid [TYPE erl-pid  8 0 0]
>>
>>   are you using flymake? I've had problems using edb and flymake
>>  together...
>>
>
> I am, and turning flymake off fixed the problem, thanks, Ill take a shot at
> actually debugging the flymake vs edb now.


  oops. perhaps I should've mentioned that I've fixed it...

  you might want to take a look at
  http://github.com/massemanet/erlware-mode/tree/master


More information about the erlang-questions mailing list