[erlang-questions] dialyzer fails when using packages and -r

Kostis Sagonas <>
Wed Jan 7 15:30:01 CET 2009


David Sveningsson wrote:
> 
> Hi, I ran into some issues when trying to run dialyzer on some source
> code I wrote. I rewrote a module called discovery into a package in the
> src/discovery directory. I want to run dialyzer to analyze the code and
> the package. Dialyzer worked fine before the splitting to a package. Any
> ideas what might be wrong?

This is a known issue.  Dialyzer does not support packages (at least not 
yet) but the situation is not that different than those of many other 
tools that manipulating Erlang code, which currently do not support 
packages either.  Supporting packages is on our TODO list, but its 
priority is quite low and the decision to promote it to a higher 
priority is to some extent dependent on the general future of packages 
in Erlang.

Kostis

PS. Personally, I am positively inclined towards packages, but only
     mildly so.



More information about the erlang-questions mailing list