[erlang-questions] erlang emacs mode question

Joe Armstrong <>
Tue Dec 15 14:51:07 CET 2009


Sorry last posting got posted too early when I hit a tab :-)

The line following ${, moves too far to the right when I hit tab
I guess it's confused by the ${

(With  comment-multi-line = true)

/Joe


On Tue, Dec 15, 2009 at 2:48 PM, Joe Armstrong <> wrote:
> I'd missed this. Seems to work very nicely apart from a bug in func9 -
> tab on the commented line indents
> like this:
>
> func9(Term, [${|T]) ->
>             % above should be highlighted correctly
>             % all function body lines should not indent further on tab
>             T.
>
>
> And not like this:
>
> func9(Term, [${|T]) ->
> % above should be highlighted correctly
>             % all function body lines should not indent further on tab
>             T.
>
> On Mon, Dec 14, 2009 at 11:28 PM, Logan, Martin <> wrote:
>> BTW,  the erlware erlang mode "erlware-mode" is much better than the erlang mode.  Many bugs have been fixed and the skeletons are all edoc'd.  It has been well maintained for over 2 years and is now way ahead IMHO.  You can find it at erlware.org or over at the google code site code.google.com/p/erlware-mode
>>
>> Cheers,
>> Martin
>>
>>
>> On 12/14/09 10:36 AM, "Göran Båge" <> wrote:
>>
>> Thanks Dan,
>>
>> Yes it worked in R13B03, adding '%% ' and removing '%% '. Just my kind
>> of timing bringing it up just when it was fixed, it's been bugging me for
>> quite some time before I got around to asking:-). We are very slow
>> moving to new releases as we have long lived products running out there,
>> we still have some R9 based ones and I've not run R13 before, just installed
>> it as a matter of fact.
>>
>> Cheers
>> --Göran
>>
>> Dan Gudmundsson wrote:
>>> On Mon, Dec 14, 2009 at 4:56 PM, Göran Båge<>  wrote:
>>>> Hi,
>>>>
>>>> Is there a reason why the erlang emacs mode treats comment (^C^C) and
>>>> un-comment
>>>> (^C^U) asymmetrical, comment adds '%% ' and uncomment removes '%'. Pretty
>>>> annoying if you ask me (but who would even think of doing that :-). It used
>>>> to work by adding only '%' earlier (maybe very much earlier like in R9 or
>>>> so).
>>>
>>> Have you tried the latest erlang mode, on github or in R13B03?
>>>
>>> Both ^U^C^C and ^C^U works for me.
>>>
>>> /Dan
>>> PS: There are a lot of changes in the latest release of the erlang emacs mode,
>>>         so if we broke something please report or even better post a patch.
>>
>> --
>> -- Goran
>> --------------------- May the Snow be with you --------
>>  Goran Bage         MobileArts        www.mobilearts.se
>>  Tjarhovsgatan 56  SE-116 28 STOCKHOLM           Sweden
>>           phone: +46 733 358405
>>
>> ________________________________________________________________
>> erlang-questions mailing list. See http://www.erlang.org/faq.html
>> erlang-questions (at) erlang.org
>>
>>
>>
>


More information about the erlang-questions mailing list