[erlang-questions] lists:unzip breaks dialyzer.

Gleb Peregud <>
Tue Jun 17 16:28:49 CEST 2008


On Tue, Jun 17, 2008 at 4:11 PM, Adam Kelly <> wrote:
> On Tue, Jun 17, 2008 at 2:07 PM, Tobias Lindahl <> wrote:
>> However, you are running R11B-5, and I have fixed the bug since then. I
>> suggest you upgrade if you can.
>
> Good to know, thank you (and Kostis).  Yes, it appears we're suffering
> from Ubuntu packages being nearly a year old even in the latest release.   I've
> worked around the problem for now, and we'll have to plan an upgrade.
>
> Adam.


There's an updated version in intrepid repositories:
http://packages.ubuntu.com/intrepid/erlang (unfortunatly it is still R12B-2)
and if they become older then Debian you may rebuilt them for Ubuntu
using the following instructions
http://gleber.pl/blog/2008/02/12/16/building-erlang-12b-on-ubuntu-gutsy/

P.S. I just couldn't stand posting link to my own blog ^^

-- 
Gleb Peregud
http://gleber.pl/

Every minute is to be grasped.
Time waits for nobody.
-- Inscription on a Zen Gong



More information about the erlang-questions mailing list