[erlang-questions] posregex error: RE_drv not found

Anders Nygren <>
Fri Oct 5 13:54:46 CEST 2007


On 10/5/07, YC <> wrote:
> Hi -
>
> I downloaded posregex and compile on my machine per the suggestion of the
> thread
> http://www.erlang.org/pipermail/erlang-questions/2007-September/029492.html
> .   I'm able to make and sudo make install, but when I try to run it in
> erlang I encounter the following message:
>
> 2> {ok, RE} = posregex:compile(<<"abc.*def">>,[extended]).
> sh: line 0: exec: RE_drv: not found
>
>  BREAK: (a)bort (c)ontinue (p)roc info (i)nfo (l)oaded
>        (v)ersion (k)ill (D)b-tables (d)istribution
>
> And not sure how to proceed from here.  I tried both 1.0 & 1.0.1 with the
> same results.
>
> Any insights are appreciated, thanks.
>
> yc
>

I think Your Erlang system is broken. I recently had a similar problem, and
it was solved by recompiling erlang with a different gcc version.
The problem is that with the bad compiler version erlang is not able to
load any drivers.

If You try
crypto:start()
and it also fails, it is probably the same problem as I had.

/Anders



More information about the erlang-questions mailing list