[erlang-questions] Compiling erlang on AIX 5.3

VAUCHER Laurent <>
Fri Feb 9 09:30:19 CET 2007


> > === Entering application parsetools
> > make[3]: Entering directory `/tmp/otp_src_R11B-2/lib/parsetools/src'
> > erlc -W   +debug_info -I/tmp/otp_src_R11B-2/lib/stdlib/include
-o../ebin
> > yecc.erl
> > Could not load program
> > /tmp/otp_src_R11B-2/bin/powerpc-ibm-aix5.3.0.0/beam:
> >         The program does not have an entry point or
> >           the o_snentry field in the auxiliary header is invalid.
> > Examine file headers with the 'dump -ohv' command.
> 
> Hard to say without seeing the complete build log and "config.log",
but using Google there seem to be two main causes for this on AIX
>
>  - Somehow the build put in "-G" or "-shared" on the link line
>    of the "beam" executable.
>
>  - "ld" was used to link the final application "beam", this will not
>    work on AIX. The "gcc" or "xlc_r" command should be used for
>    linking, as it "knows things" about runtime library dependencies,
>    entry points etc that a plain "ld" has no idea about.
>
> The problem with using "ld" is described at page 73 in
>
>
http://jumpdoc.fz-juelich.de/doc_pdf/compiler/SG24-5674-01a-CandC++.pdf
>
> kent

  This explanation makes real sense. But now, how do I tell configure
not to look for 'ld' but use gcc instead?
I've tried --with-ld=gcc. I've tried forcefully replacing ld by gcc
(which does not work at all). I've tried 'export LD=gcc'...

I can't find a way to do it and I can't find any documentation.


Laurent.






More information about the erlang-questions mailing list