[erlang-questions] Erlide & Eclipse version

Vlad Dumitrescu <>
Tue Dec 18 15:36:00 CET 2007


On Dec 18, 2007 3:14 PM, Michael Campbell <> wrote:
> This is probably an extreme edge case, but...  IBM's suite of eclipse
> based tools are currently based on 3.1 (!).  The 3.2 versions are
> rumored to be out in a few days.
>
> What about 3.3 is compelling enough to consider this?

Well, there is a lot of stuff that is better/faster/prettier in 3.3.
There are new APIs that allow hooking into existing functionality
instead of having to copy Eclipse code into one's own code tree and
hack it - keeping that updated with the latest Eclipse fixes would
require at least a person working full time with that.

Do you currently run Erlide on 3.1? Does it work?

The compromise will have to be made between not shutting out a part of
the user base and keeping up with the general Eclipse development. We
don't have resources to develop several versions in parallel.

A possible solution is to have the basic functionality in 3.2-based
plugins and if one runs 3.3 then one can install the "bonus material".
We will have to think about this and see how we can best solve it.

On a related note, 3.4 is to be out in a few months :-)

Thanks everybody for the input!
best regards,
Vlad



More information about the erlang-questions mailing list