[erlang-questions] R11B-1 on SPARC Solaris 10?

Jason Tucker <>
Tue Oct 17 20:36:22 CEST 2006


Has anyone successfully built R11B-1 on Solaris 10 SPARC? I have
successfully built just about every version, including R11B-0, but R11B-1
fails miserably at 'make depend', and I've been unsuccessful so far in
trying to trace down the problem. NOTE that I can get it to build on Solaris
9... just not 10. I'm continuing to look into it, but if anyone has any gems
of wisdom that might help out, I'd appreciate it:

[ otp_src_R11B-1]$gmake depend
cd erts/emulator && ERL_TOP=/home/jtucker/src/otp_src_R11B-1 gmake generate
depend
gmake[1]: Entering directory
`/home/jtucker/src/otp_src_R11B-1/erts/emulator'
gmake -f sparc-sun-solaris2.10/Makefile generate
gmake[2]: Entering directory
`/home/jtucker/src/otp_src_R11B-1/erts/emulator'
LANG=C /usr/bin/perl5 utils/beam_makeops -outdir
sparc-sun-solaris2.10/opt/plain
\
        -emulator
/home/jtucker/src/otp_src_R11B-1/lib/compiler/src/genop.tab beam/ops.tab
beam/frag_ops.tab hipe/hipe_ops.tab
LANG=C /usr/bin/perl5 utils/make_tables -src sparc-sun-solaris2.10 -include
sparc-sun-solaris2.10 beam/atom.names beam/bif.tab hipe/hipe_bif0.tab
hipe/hipe_bif1.tab hipe/hipe_bif2.tab hipe/hipe_sparc.tab
LANG=C /usr/bin/perl5 utils/make_version -o sparc-sun-solaris2.10/erl_version.h
R11B 5.5.1 sparc-sun-solaris2.10
LANG=C /usr/bin/perl5 utils/make_driver_tab -o
sparc-sun-solaris2.10/driver_tab.c
obj/sparc-sun-solaris2.10/opt/plain/efile_drv.o
obj/sparc-sun-solaris2.10/opt/plain/ddll_drv.o
obj/sparc-sun-solaris2.10/opt/plain/inet_drv.o obj/sparc-
sun-solaris2.10/opt/plain/zlib_drv.o
obj/sparc-sun-solaris2.10/opt/plain/ram_file_drv.o obj/sparc-sun-solaris2.10
/opt/plain/ttsl_drv.o
LANG=C /usr/bin/perl5 utils/make_alloc_types -src beam/erl_alloc.types -dst
sparc-sun-solaris2.10 /opt/plain/erl_alloc_types.h threads hipe unix
cd /home/jtucker/src/otp_src_R11B-1/lib/kernel/ebin/../src && gmake
../ebin/otp_ring0.beam
gmake[3]: Entering directory
`/home/jtucker/src/otp_src_R11B-1/lib/kernel/src'
erlc -W   +debug_info +strict_record_tests -I../include -o../ebin
otp_ring0.erl
gmake[3]: erlc: Command not found
gmake[3]: *** [../ebin/otp_ring0.beam] Error 127
gmake[3]: Leaving directory
`/home/jtucker/src/otp_src_R11B-1/lib/kernel/src'
gmake[2]: ***
[/home/jtucker/src/otp_src_R11B-1/lib/kernel/ebin/otp_ring0.beam] Error 2
gmake[2]: Leaving directory `/home/jtucker/src/otp_src_R11B-1/erts/emulator'
gmake[1]: *** [generate] Error 2
gmake[1]: Leaving directory `/home/jtucker/src/otp_src_R11B-1/erts/emulator'

gmake: *** [depend] Error 2

__Jason
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://erlang.org/pipermail/erlang-questions/attachments/20061017/4ad72e80/attachment.html>


More information about the erlang-questions mailing list