[erlang-questions] Starting crypto app in werl

Michael McDaniel <>
Fri Nov 24 21:45:37 CET 2006


  Hmm, maybe I'm steering you wrong and you do not need the openssl dlls.

  I checked my R11B-2 installation on Windows XP and have

  C:\Program Files\erl5.5.2\lib\crypto-1.5\priv\lib\crypto_drv.dll

  but there is no

    C:\Program Files\erl5.5.2\lib\crypto-1.5\priv\lib\win32 directory

  at all

~M


On Sat, Nov 25, 2006 at 12:30:16AM +0400, Gurgen Tumanian wrote:
> 
> Guess i have none of them.
> Still, i launched sasl before crypto, a got the following
> 
> =CRASH REPORT==== 25-Nov-2006::00:25:31 ===
>   crasher:
>     pid: <0.55.0>
>     registered_name: crypto_server
>     error_info: {einval,[{erlang,open_port,
>                                   [{spawn,
>                                        "crypto_drv elibcrypto c:/PROGRA~1/
> ERL55~
> 1.1/lib/crypto-1.5/priv/lib/win32/elibcrypto"},
>                                    []]},
>                           {crypto_server,init,1},
>                           {gen_server,init_it,6},
>                           {proc_lib,init_p,5}]}
>     initial_call: {gen,init_it,
>                       [gen_server,
>                        <0.54.0>,
>                        <0.54.0>,
>                        {local,crypto_server},
>                        crypto_server,
>                        [],
>                        []]}
>     ancestors: [crypto_sup,< 0.53.0>]
>     messages: []
>     links: [<0.54.0>]
>     dictionary: []
>     trap_exit: true
>     status: running
>     heap_size: 987
>     stack_size: 21
>     reductions: 694
>   neighbours:
> {error,{shutdown,{crypto_app,start,[normal,[]]}}}
>  
> !DSPAM:52,45675691251561919120578!

> _______________________________________________
> erlang-questions mailing list
> 
> http://www.erlang.org/mailman/listinfo/erlang-questions
> 
> 
> !DSPAM:52,45675691251561919120578!


-- 
Michael McDaniel
Portland, Oregon, USA
http://autosys.us
+1 503 283 5284



More information about the erlang-questions mailing list