[erlang-questions] Erlang doesn't like ubuntu 6.10

ke han <>
Wed Nov 8 17:41:38 CET 2006


Tobias,
I am installing erlang on ubuntu for the  first time.  It is OTP  
R11B-1 on "ubuntu 6.06.1 server".
This is a new install of ubuntu and all I added after the install was:
openssh, build-essential, libncurses5-dev, libssl-dev and openssl.
These last three items I added in order to get ./configure to work.

When I run make, it dies as follows:

:~/otp_src_R11B-1$ make
cd erts/emulator && ERL_TOP=/home/jhancock/otp_src_R11B-1 make  
generate depend
make[1]: Entering directory `/home/jhancock/otp_src_R11B-1/erts/ 
emulator'
make -f i686-pc-linux-gnu/Makefile generate
make[2]: Entering directory `/home/jhancock/otp_src_R11B-1/erts/ 
emulator'
/bin/mkdir -p i686-pc-linux-gnu/opt/plain
/bin/mkdir -p obj/i686-pc-linux-gnu/opt/plain
LANG=C /usr/bin/perl utils/beam_makeops -outdir i686-pc-linux-gnu/opt/ 
plain \
                 -emulator /home/jhancock/otp_src_R11B-1/lib/compiler/ 
src/genop.tab beam/ops.tab beam/frag_ops.tab hipe/hipe_ops.tab
LANG=C /usr/bin/perl utils/make_tables -src i686-pc-linux-gnu - 
include i686-pc-linux-gnu beam/atom.names beam/bif.tab hipe/ 
hipe_bif0.tab hipe/hipe_bif1.tab hipe/hipe_bif2.tab hipe/hipe_x86.tab
LANG=C /usr/bin/perl utils/make_version -o i686-pc-linux-gnu/ 
erl_version.h R11B 5.5.1 i686-pc-linux-gnu
LANG=C /usr/bin/perl utils/make_driver_tab -o i686-pc-linux-gnu/ 
driver_tab.c obj/i686-pc-linux-gnu/opt/plain/efile_drv.o obj/i686-pc- 
linux-gnu/opt/plain/ddll_drv.o obj/i686-pc-linux-gnu/opt/plain/ 
inet_drv.o obj/i686-pc-linux-gnu/opt/plain/zlib_drv.o obj/i686-pc- 
linux-gnu/opt/plain/ram_file_drv.o obj/i686-pc-linux-gnu/opt/plain/ 
ttsl_drv.o
LANG=C /usr/bin/perl utils/make_alloc_types -src beam/erl_alloc.types  
-dst i686-pc-linux-gnu/opt/plain/erl_alloc_types.h threads hipe unix
LANG=C /usr/bin/perl utils/make_preload -old /home/jhancock/ 
otp_src_R11B-1/lib/kernel/ebin/otp_ring0.beam /home/jhancock/ 
otp_src_R11B-1/lib/kernel/ebin/init.beam /home/jhancock/ 
otp_src_R11B-1/lib/kernel/ebin/prim_inet.beam /home/jhancock/ 
otp_src_R11B-1/lib/kernel/ebin/prim_file.beam /home/jhancock/ 
otp_src_R11B-1/lib/kernel/ebin/erl_prim_loader.beam /home/jhancock/ 
otp_src_R11B-1/lib/kernel/ebin/erlang.beam > i686-pc-linux-gnu/preload.c
m4  -DTARGET=i686-pc-linux-gnu -DOPSYS=linux -DARCH=x86 hipe/ 
hipe_x86_asm.m4 > i686-pc-linux-gnu/opt/plain/hipe_x86_asm.h
/bin/sh: m4: command not found
make[2]: *** [i686-pc-linux-gnu/opt/plain/hipe_x86_asm.h] Error 127
make[2]: Leaving directory `/home/jhancock/otp_src_R11B-1/erts/emulator'
make[1]: *** [generate] Error 2
make[1]: Leaving directory `/home/jhancock/otp_src_R11B-1/erts/emulator'
make: *** [depend] Error 2

Any idea what I need to have on ubuntu 6.06.1 server in order to get  
a good compile??

thanks, ke han


On Nov 6, 2006, at 8:04 AM, Tobias Löfgren wrote:

>
> Just a heads up for anyone else who uses Ubuntu. Erlang seems to  
> have trouble loading external libraries/driver on a Ubuntu 6.10  
> "Egdy Eft" system.
>
> I've just spent the better part of the weekend trying to figure out  
> what was going wrong. First it seemed like a problem with Yaws,  
> because erlang compiled fine and "worked". But yaws stopped with a  
> "exec 1: setuid_drv.so :not found".
>
> After much reinstalling and experimenting with different versions I  
> discovered that it was all dynamic loading of libraries that  
> failed. For example "crypto:start()." in the erl shell crashed in a  
> similar fashion.
>
> Maybe there is a simple solution to the problem, but at the moment  
> it eludes me, so I've downgraded. The same packages and erlang- 
> versions work perfectly fine in Ubuntu 6.06, so if you're using  
> Ubuntu and Erlang, don't upgrade ubuntu yet.
>
>
> /tobias
>
>
>
> _______________________________________________
> erlang-questions mailing list
> 
> http://www.erlang.org/mailman/listinfo/erlang-questions





More information about the erlang-questions mailing list