R11B installation problem on debian

Roberto Saccon <>
Sat Aug 5 21:41:56 CEST 2006


I have previously successfully installed Erlang  R11B on my Ubuntu
machine, now I tried on a debian sarge server and after some minutes
of compiling, I got an error.

Here what I did:

wget http://erlang.org/download/otp_src_R11B-0.tar.gz
mkdir /usr/local/erlang
cd /usr/local/erlang
gunzip -c  /home/myuser/otp_src_R11B-0.tar.gz | tar xfp -
cd otp_src_R11B-0
LANG=C; export LANG
./configure
make

---------------------------------- Compilation output just before error:

make[1]: Entering directory `/usr/local/erlang/otp_src_R11B-0/erts'
make[2]: Entering directory
`/usr/local/erlang/otp_src_R11B-0/erts/start_scripts'
sed -e 's;%SYS_VSN%;R11B;' \
            -e 's;%ERTS_VSN%;5.5;' \
            -e 's;%KERNEL_VSN%;2.11;' \
            -e 's;%STDLIB_VSN%;1.14;' \
          /usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_clean.rel.src
> /usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_clean.rel
sed -e 's;%SYS_VSN%;R11B;' \
            -e 's;%ERTS_VSN%;5.5;' \
            -e 's;%KERNEL_VSN%;2.11;' \
            -e 's;%STDLIB_VSN%;1.14;' \
            -e 's;%SASL_VSN%;2.1.2;' \
          /usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_sasl.rel.src
> /usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_sasl.rel
sed -e 's;%SYS_VSN%;R11B;' \
            -e 's;%ERTS_VSN%;5.5;' \
            -e 's;%KERNEL_VSN%;2.11;' \
            -e 's;%STDLIB_VSN%;1.14;' \
            -e 's;%SASL_VSN%;2.1.2;' \
            -e 's;%OS_MON_VSN%;2.1;' \
            -e 's;%MNESIA_VSN%;4.3.1;' \
            -e 's;%SNMP_VSN%;;' \
            -e 's;%INETS_VSN%;4.7.4;' \
          /usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_all_example.rel.src
> /usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_all_example.rel
/usr/bin/install -c -d /usr/local/erlang/otp_src_R11B-0/erts/start_scripts/tmp
( cd /usr/local/erlang/otp_src_R11B-0/erts/start_scripts/tmp && \
erlc -W   -I/usr/local/erlang/otp_src_R11B-0/lib/kernel/ebin
-I/usr/local/erlang/otp_src_R11B-0/lib/stdlib/ebin
-I/usr/local/erlang/otp_src_R11B-0/lib/sasl/ebin -o
/usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_clean.script
/usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_clean.rel )
stdlib: File not found: "stdlib.app"

make[2]: *** [/usr/local/erlang/otp_src_R11B-0/erts/start_scripts/start_clean.script]
Error 1
make[2]: Leaving directory
`/usr/local/erlang/otp_src_R11B-0/erts/start_scripts'make[1]: ***
[local_setup] Error 2
make[1]: Leaving directory `/usr/local/erlang/otp_src_R11B-0/erts'
make: *** [local_setup] Error 2
debian:/usr/local/erlang/otp_src_R11B-0#

--------------------------------------------------------


"stdlib.app" did not get created, but I am not familar yet with the
buildsystem and don't know where and why that happend.

Anybody knows what I need to do to make it work, or at least where I
should start to troubleshoot ?

-- 
Roberto Saccon



More information about the erlang-questions mailing list