choice of gcc version for Erlang on ARM/XScale/PXA

Mikael Pettersson <>
Wed Nov 30 14:50:40 CET 2005


Brian Zhou writes:
 > Mikael Pettersson <mikpe <at> user.it.uu.se> writes:
 > 
 > > 
 > > Could those that have built Erlang for ARM/XScale/PXA
 > > machines please report exactly which gcc versions they
 > > have been using, including what ARM patches if any they
 > > applied to gcc?
 > > 
 > > /Mikael
 > > 
 > 
 > Cross compile on i686 Linux with gcc-3.3.5-glibc-2.2.5 targeting nslu2-linux.
 > http://cvs.sourceforge.net/viewcvs.py/nslu/unslung/make/erlang.mk?view=log

My gcc-3.3.6 on armv5b does not have the bug, so your gcc-3.3.5 is
most likely also OK.



More information about the erlang-questions mailing list