Yaws + SSL + POST HTTP

Sean Hinde <>
Tue Jun 14 20:35:35 CEST 2005


Interesting.

{get_more, Cont, State} should only ever be required when the  
partial_post_size configuration is set. It should have nothing to do  
with the SSL buffer size - without this config Yaws will accumulate  
the whole POST body and deliver it to the callback in one piece.

So, do you have the partial_post_size Yaws config parameter set? If  
so does it work without this (or with it set to the atom 'nolimit')  
but with the smaller SSL buffer size?

Sean

On 14 Jun 2005, at 19:27, Inswitch Solutions wrote:

>
> I've recompiled under win32 (Windows 2000) the SSL port.(ssl_esock) 
> with
> #define RWBUFLEN 120*1024
>  in esock.c.  This buffer value elimantes the need for {get_more,  
> Cont,
> State} on HTTP read when trying to upload a file of 120kb.
>
>
> regards, Eduardo
>
>
> ----- Original Message -----
> From: "Sean Hinde" <>
> To: "Inswitch Solutions" <>
> Cc: <>
> Sent: Tuesday, June 14, 2005 3:06 PM
> Subject: Re: Yaws + SSL + POST HTTP
>
>
>
>> How did you apply the patch? did you actually re-compile esock.c and
>> the ssl driver under windows? Using cygwin?
>>
>> Sean
>>
>> On 14 Jun 2005, at 18:34, Inswitch Solutions wrote:
>>
>>
>>> Sean,
>>>
>>> I've tried to use 32*1024 (32kb) size as the patch does but it
>>> doesn't work
>>> also.
>>> In this case the same error ocurrs (the page cannot be shown).
>>>
>>> I've increased it to 130*1024 (130kb) and now it works correctly.
>>> It seems as in Win32 the yaws directive:
>>> . {get_more, Cont, State}
>>>
>>> is not working correctly.
>>>
>>>
>>>
>>> thanks again,   Eduardo Figoli
>>>
>>>
>>>
>>>
>>>
>>> thanks,
>>> Eduardo Figoli
>>>
>>>
>>> ----- Original Message -----
>>> From: "Sean Hinde" <>
>>> To: "Inswitch Solutions" <>
>>> Cc: <>
>>> Sent: Tuesday, June 14, 2005 2:14 PM
>>> Subject: Re: Yaws + SSL + POST HTTP
>>>
>>>
>>>
>>>
>>>> I didn't mean yaws, I meant the patch to the SSL driver:
>>>>
>>>> http://forums.trapexit.org:81/phpBB/viewtopic.php?t=4870
>>>>
>>>> Sean
>>>>
>>>> On 14 Jun 2005, at 18:02, Inswitch Solutions wrote:
>>>>
>>>>
>>>>
>>>>> Hi Sean,
>>>>>
>>>>> I have installed the latest Yaws 1.55 but it doesn't work neither.
>>>>> Using upload.yaws I've seen that with small files (4kb) the upload
>>>>> works but
>>>>> with larger ones no (120kb).
>>>>> Any ideas?
>>>>>
>>>>>
>>>>> thanks,
>>>>> Eduardo Figoli
>>>>>
>>>>>
>>>>> ----- Original Message -----
>>>>> From: "Inswitch Solutions" <>
>>>>> To: "Sean Hinde" <>
>>>>> Cc: <>
>>>>> Sent: Monday, June 13, 2005 5:53 PM
>>>>> Subject: Re: Yaws + SSL + POST HTTP
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>> No, will do.
>>>>>>
>>>>>> Thanks.
>>>>>> Eduardo
>>>>>> ----- Original Message -----
>>>>>> From: "Sean Hinde" <>
>>>>>> To: "Inswitch Solutions" <>
>>>>>> Cc: <>
>>>>>> Sent: Monday, June 13, 2005 5:50 PM
>>>>>> Subject: Re: Yaws + SSL + POST HTTP
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>> Have you tried applying the patch to the SSL driver recently
>>>>>>> described on the mailing list?
>>>>>>>
>>>>>>> Sean
>>>>>>>
>>>>>>>
>>>>>>> On 13 Jun 2005, at 21:45, Inswitch Solutions wrote:
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>> Hi Sean,
>>>>>>>>
>>>>>>>> Yes it works perfectly.
>>>>>>>>
>>>>>>>> Eduardo
>>>>>>>>
>>>>>>>>
>>>>>>>> ----- Original Message -----
>>>>>>>> From: "Sean Hinde" <>
>>>>>>>> To: "Inswitch Solutions" <>
>>>>>>>> Cc: <>
>>>>>>>> Sent: Monday, June 13, 2005 5:42 PM
>>>>>>>> Subject: Re: Yaws + SSL + POST HTTP
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>>
>>>>>>>>> On 13 Jun 2005, at 21:12, Inswitch Solutions wrote:
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>> Hi,
>>>>>>>>>>
>>>>>>>>>> I'm having problems with Yaws+SSL and the following HTML :
>>>>>>>>>> <form name="form" method="post" action="/eVoucher/
>>>>>>>>>> controller.yaws"
>>>>>>>>>> enctype="multipart/form-data">
>>>>>>>>>>
>>>>>>>>>> The POST HTTP request over and SSL connection is not  
>>>>>>>>>> correctly
>>>>>>>>>> been
>>>>>>>>>> handled by the Yaws web server.
>>>>>>>>>> Any ideas? Do I have to use another enc MIME-type?
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>> This looks fine. Does it work without SSL?
>>>>>>>>>
>>>>>>>>> See the file upload example for an example of usage of this
>>>>>>>>> enctype:
>>>>>>>>>
>>>>>>>>> http://yaws.hyber.org/upload0.yaws
>>>>>>>>>
>>>>>>>>> Sean
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>
>>>>
>>>>
>>>>
>>>
>>>
>>>
>>>
>>
>>
>>
>
>
>




More information about the erlang-questions mailing list